Results 1 to 19 of 19

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: 3.0 beta 4 iTunes reports "software has expired"

  1. #1
    Exclamation 3.0 beta 4 iTunes reports "software has expired"
    Hi I did post this in another thread by mistake

    The problem I have is someone changed the date on my phone to the year 2012 and now all the phone shows is the emergency call only screen. When I plug it into my mac iTunes reports "the software in the iPhone has expired and must be updated to a newer version".

    When I try to update it with the 3.0 beta 4 file is reports that the firmware file is not compatible.

    any help would be very welcome.

    Barry

  2. #2
    What is the date on your computer?

  3. #3
    Retired Moderator StealthBravo's Avatar
    Join Date
    Jan 2008
    Location
    TX  Follow me @StealthBravo
    Posts
    32,474
    Thanks
    44
    Thanked 5,329 Times in 3,113 Posts

    Downgrade to 2.2.1 change it back then upgrade back to beta 4. Sucks I know.

  4. The Following User Says Thank You to StealthBravo For This Useful Post:

    manickbarry (2009-05-06)

  5. #4
    Quote Originally Posted by StealthBravo View Post
    Downgrade to 2.2.1 change it back then upgrade back to beta 4. Sucks I know.
    Can you explain how to do this as I am not to sure and iTunes wont let me.

    Quote Originally Posted by mattchiro View Post
    What is the date on your computer?
    The date on the computer is current.
    Last edited by manickbarry; 2009-05-05 at 07:42 AM. Reason: Automerged Doublepost

  6. #5
    Retired Moderator StealthBravo's Avatar
    Join Date
    Jan 2008
    Location
    TX  Follow me @StealthBravo
    Posts
    32,474
    Thanks
    44
    Thanked 5,329 Times in 3,113 Posts

    If you had SSH installed you might want to try to SSH in and change the date manually. I don't know how off hand. Google it. If you can't or don't have SSH installed then you will have to downgrade.

    You need to use iTunes 8.1 to go back to 2.2.1. After installing 8.1, put your phone in DFU Mode and restore to 2.2.1. It will give you an error after the restore, probably like 1604 or something similar, use the QuickPWN for 2.2.1 and jailbreak it. That will pull it out of recovery and bring you to a normal OS. Change your date to the current date.

    Then install 8.2 and restore to Beta 4 again. Use the QuickPWN for beta 4 to jailbreak and start over.

  7. The Following User Says Thank You to StealthBravo For This Useful Post:

    manickbarry (2009-05-05)

  8. #6
    Quote Originally Posted by StealthBravo View Post
    If you had SSH installed you might want to try to SSH in and change the date manually. I don't know how off hand. Google it. If you can't or don't have SSH installed then you will have to downgrade.

    You need to use iTunes 8.1 to go back to 2.2.1. After installing 8.1, put your phone in DFU Mode and restore to 2.2.1. It will give you an error after the restore, probably like 1604 or something similar, use the QuickPWN for 2.2.1 and jailbreak it. That will pull it out of recovery and bring you to a normal OS. Change your date to the current date.

    Then install 8.2 and restore to Beta 4 again. Use the QuickPWN for beta 4 to jailbreak and start over.
    Thanks for the reply I really appreciate the help but QuickPWN wont see the phone I have used iTunes 8.1 and restored to 2.2.1 and iTunes can see the phone but not QuickPWN any ideas.

    thanks again
    Barry

  9. #7
    You are using quickpwn 2.2.5-2?
    He who asks a question looks foolish for 5 minutes. He who doesn't ask a question remains foolish forever.

  10. #8
    Quote Originally Posted by confucious View Post
    You are using quickpwn 2.2.5-2?
    I'm I correct in thinking that is for windows as I have just tried it on my old windows box and QuickPWN now see the phone but says it has 3.0 still and wont jail break it. I have tried to restore back to 2.2.1 3 times and get the same message.

    I miss my iPhone.....

  11. #9
    That's the Window's version, yes. Quickpwn 2.2.5 for OSX should work (sorry I only use Windows).
    If quickpwn is still showing FW3.0 it sounds like you haven't restored 2.21 properly.
    Try entering DFU mode and restoring 2.21 again.
    He who asks a question looks foolish for 5 minutes. He who doesn't ask a question remains foolish forever.

  12. The Following User Says Thank You to confucious For This Useful Post:

    manickbarry (2009-05-06)

  13. #10
    Retired Moderator StealthBravo's Avatar
    Join Date
    Jan 2008
    Location
    TX  Follow me @StealthBravo
    Posts
    32,474
    Thanks
    44
    Thanked 5,329 Times in 3,113 Posts

    You are not on 2.2.1 then. Follow the instructions again. Use DFU mode like confucious says.

  14. The Following User Says Thank You to StealthBravo For This Useful Post:

    manickbarry (2009-05-06)

  15. #11
    Quote Originally Posted by StealthBravo View Post
    You are not on 2.2.1 then. Follow the instructions again. Use DFU mode like confucious says.
    Thank you sooo much I had to do it on windows in the end but it would only restore back to 2.2.1 from iTunes 8.2 once that was done it was all good.

    I love you guys I am so happy now many many many thanks.

    Barry

  16. #12
    Retired Moderator StealthBravo's Avatar
    Join Date
    Jan 2008
    Location
    TX  Follow me @StealthBravo
    Posts
    32,474
    Thanks
    44
    Thanked 5,329 Times in 3,113 Posts

    Happy to hear that!

  17. #13
    I have done this all they way up to the part that is says error 1604 and i hit the x to close the window and try and run Quickpwn. It never detects my iphone! I've tried ti with itunes 8.1 and 8.2! I've also tried it with Quickpwn 2.2.1 and 2.2.5! Lo luck!! Can some one please help me??

  18. #14
    Quote Originally Posted by jon1971 View Post
    I have done this all they way up to the part that is says error 1604 and i hit the x to close the window and try and run Quickpwn. It never detects my iphone! I've tried ti with itunes 8.1 and 8.2! I've also tried it with Quickpwn 2.2.1 and 2.2.5! Lo luck!! Can some one please help me??
    All I can tell you in I used iTunes 8.2 to restore back to 2.2.1 you must have your phone in DFU mode (when in DFU mode the phone screen will be black) if using windows hold shift and click restore and browse to the 2.2.1 ipsw file. Then use QuickPWN 2.2.5-5 and jailbreak. When I restored to 2.2.1 I could not a signal on the phone so I had to go back to 3.o I know some people have said they have successfully gone back but it only enabled me to change the date on the phone so I could go back to 3.0.

  19. #15
    Quote Originally Posted by jon1971 View Post
    I have done this all they way up to the part that is says error 1604 and i hit the x to close the window and try and run Quickpwn. It never detects my iphone! I've tried ti with itunes 8.1 and 8.2! I've also tried it with Quickpwn 2.2.1 and 2.2.5! Lo luck!! Can some one please help me??
    Have you tried Quickpwn 2.25-2?
    He who asks a question looks foolish for 5 minutes. He who doesn't ask a question remains foolish forever.

  20. #16
    I have exactly the same problem and it happen 3 days ago while I was away on a trip with my beta 3. Ironically, I didn't want to update at literally the last minute and have to restore all the music I was going to need while travelling! Despite efforts to update in the little time I had while away, I kept getting the same damn error. I was blaming the apple-usb conversion on the mophie juicepack but I saw soon as I got home this evening this was not the issue. So I just follow the advice here and installed itunes 8.2 and got the frigging 1603 error. I just tried again to downgrade and yet again for something like the 8th time since yesterday got another 1604 error. It's is now 12 pm. What has really annoyed the sh*t out of me as I've have no access to a phone number that I needed today while travelling, not stored on the sim (thanks to iphone not doing that). I am ready to smash the the thing right now! As a person very good with diagnosing software issues, this has me at the end of my tether...
    Last edited by Ozdude; 2009-05-10 at 04:17 PM.

  21. #17
    When downgrading ignore error, just use quickpwn after the error in itunes.

  22. #18
    yes ignore the error and quickpwn didn't work for me at first I had to restart it a couple of times and put it into DFU mode. Persistence and you will be fine

  23. #19
    Quote Originally Posted by manickbarry View Post
    yes ignore the error and quickpwn didn't work for me at first I had to restart it a couple of times and put it into DFU mode. Persistence and you will be fine
    I tried quickpwn 2 days ago and it won't even recognise my iphone in DFU mode or otherwise. Persistence... if it doesn't work in the next couple of hours I am going to scream. I have effectively been out of contact for 3 days now!

    EDIT: Ok I just tried downgrading from my office PC and got error 1310. So in between trying to get quickpwn to recognise the phone I took out the sim card and put in my old N95 so I could be back in contact finally. In doing so the iphone came up with the activation screen all of sudden, saying it needed a sim! So after all that sh*t, I reckon pulling the sim would have sorted the issue for me. Anyway I'm back in business, thank f*. Next step back up to beta 5 since I can't use my existing backed up data with 2.2.1.
    Last edited by Ozdude; 2009-05-11 at 03:59 AM.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •