Results 1 to 9 of 9

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: iphone unlocking/jailbreaking help (2.2.1)

  1. #1
    Default iphone unlocking/jailbreaking help (2.2.1)
    i have a 2.2.1 iphone with baseband 2.30.03 i want to jailbreak it and ultimately unlock it i have been away from the iphone scene for a while so im not too sure about whats been going on can someone advise me as to how to go about jailbreaking and unlocking it?

  2. #2
    Retired Moderator bhz1's Avatar
    Join Date
    Sep 2007
    Location
    Southeastern Pennsylvania
    Posts
    2,528
    Thanks
    92
    Thanked 361 Times in 271 Posts

    It all depends upon which bootloader you have. If you have 5.8 then you can downgrade the baseband. If you have 5.9 you can't. Download "3G Baseband Downgrade" from Cydia. It will only do its job if you have the correct bootloader.

    Alternatively, you can search for info on using 'Minicom" and SSH to determine which bootloader you haveand then use the 3G baseband downgrader if you have the proper bootloader. If you do successfully downgrade the baseband, you can then download "Yellowsn0w" from Cydia and unlock your phone.

  3. The Following 2 Users Say Thank You to bhz1 For This Useful Post:

    mYiPhOnE7 (2009-05-07), number14 (2009-05-04)

  4. #3
    do i have to jailbreak 2.2.1 in order to get cydia then?

  5. #4
    Retired Moderator bhz1's Avatar
    Join Date
    Sep 2007
    Location
    Southeastern Pennsylvania
    Posts
    2,528
    Thanks
    92
    Thanked 361 Times in 271 Posts

    Yes, you need to jailbreak to get Cydia. Just remember that if you have bootloader 5.9 you will not be able to downgrade the baseband which means that you will not be able to unlock it. At least not at this point in time.

  6. #5
    darn it i got the 5.9 bootloader :@ oh well guess its a wait now and reasonable time as to when a possible solution will drop?

  7. #6
    Retired Moderator bhz1's Avatar
    Join Date
    Sep 2007
    Location
    Southeastern Pennsylvania
    Posts
    2,528
    Thanks
    92
    Thanked 361 Times in 271 Posts

    Haven't a clue

  8. #7
    Green Apple
    Join Date
    Jun 2008
    Location
    Palm Beach, Fl.
    Posts
    36
    Thanks
    4
    Thanked 0 Times in 0 Posts

    what is a minicom? or ssh? i'm trying to figure out what boatloader i have but i don't know how. i'm assuming i have 5.9 because i DL'd the downgrader and it's failing.
    Last edited by NOTLONUF; 2009-05-05 at 12:20 AM.

  9. #8
    Retired Moderator bhz1's Avatar
    Join Date
    Sep 2007
    Location
    Southeastern Pennsylvania
    Posts
    2,528
    Thanks
    92
    Thanked 361 Times in 271 Posts

    Quote Originally Posted by NOTLONUF View Post
    what is a minicom? or ssh? i'm trying to figure out what boatloader i have but i don't know how. i'm assuming i have 5.9 because i DL'd the downgrader and it's failing.
    You are correct. The downgrader will fail if you have 5.9.

    FYI:

    SSH- a file transfer protocol used for tranferring files to and from your iPhone

    Minicom- a console interface downloaded with Cydia to your iPhone and accessed through SSH (via Terminal on a Mac or Putty on a WIndows PC) There are certain commands that you can run to gather varios informaiton about your iPhone. Best left for expert use however before the automatied downgrader program it was what one needed to check bootloader version (maybe more, but I have bootloader 5.9 so never went further)

  10. #9
    Green Apple
    Join Date
    Jun 2008
    Location
    Palm Beach, Fl.
    Posts
    36
    Thanks
    4
    Thanked 0 Times in 0 Posts

    i know no one can really answer this for sure but do you think they will come up with a fix so that i will be able to unlock my phone even though i have 5.9?

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •