Results 1 to 6 of 6

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: No service, even with a SIM I know works in an iphone

  1. #1
    Default No service, even with a SIM I know works in an iphone
    Having struggled with jailbreak quickpwn and everything else i can find on the net to get this phone unlocked to orange i finally gave up and rest it so i could sell it.

    Totally rebooted and restored it with the latest firmware and baseband but it won't work with a known to work O2 sim. says no service.

    If i pick airplane mode on then off and wait still no service. If i go into network and pick O2 off the list is says it's restricted. (I got this far with yellowsn0w and my orange SIM also).

    Am I missing something or is the phone faulty?

  2. #2
    I've got a similar thing and from looking around I don't think we're alone. I've found a number of "Try this...." tutorials but nothing has worked yet for me.

    Does anyone have a sure-fire set of instructions to successfully activate through iTunes without downloading 2.2.1?

    I'm UK based and have an O2 (UK) SIM which activates & operates fine in my personal 8GB 3G, however I'm trying to activate another 3G phone and all I get is "Waiting for activation" on the LCD and "No Service" in the status bar. The phone can see O2 and a number of other cellular networks (Settings > Carrier) yet cannot connect to O2, presumably until the phone is activated.

    I've installed v2.2 via Alt + Restore in iTunes (phone in DFU AND also in Reovery) to retain the 02.28.00 BB. Haven't got as far as trying QuickPWN to jailbreak yet - I'd be happy (very happy) just to get the phone activated & showing service.

    Anyone have any tips for this please?

    Cheers,

    Steve

  3. #3

  4. #4
    My iPhone is a Part of Me
    Join Date
    Feb 2009
    Location
    Central PA
    Posts
    521
    Thanks
    24
    Thanked 26 Times in 26 Posts

    I don't know anything about this, but I know yell0wsnow is used for unlocking, have you tried that?

  5. #5
    Retired Moderator soulthoughts's Avatar
    Join Date
    Sep 2007
    Location
    Tacoma, WA
    Posts
    3,096
    Thanks
    333
    Thanked 603 Times in 506 Posts

    Have any of you guys tried the custom firmware in this forum?

  6. #6
    I'll give anything a try - do you have a link to any specific firmware?

    Thanks,

    Steve

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •