Results 1 to 8 of 8

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: What's the consensus on 'No Service' and 'Restricted Network' ?

  1. #1
    Default What's the consensus on 'No Service' and 'Restricted Network' ?
    Hi,

    I've now come across several unlocked / jailbroken 2G phones which show 'No Service' on the status bar yet can see a range of cellular networks when visiting Settings > Carrier.

    When attempting to join a network that's appropriate to the installed SIM the phone shows 'Your network is restricted' and offers me the chance to Dismiss or visit Settings.

    I'm perplexed. Clearly the radio hardware can see GSM networks, the SIMs work fine in other phones yet not in the supposedly 'unlocked' 2G iPhones with custom PWNed firmware.

    I've tried to reset network settings on the phone and indeed reset ALL settings without any joy. Baseband is 04.04.05_G and firmware 2.2.1

    Could anyone suggest something I might try?

    Cheers,

    Steve

    Aaaargh! Can anyone suggest something for me to try please? Sorry about replying to my own post but I'm really struggling here.

    After researching this "No Service" problem where the phone refuses to join any GSM network with a "Restricted Network" error I've done just about everything I (and others) can think of.

    Today I followed a tutorial which allowed me to downgrade from 2.x to 1.1.4 of the OS and another which taught me how to downgrade the baseband using Kiphone (on the advice of a forum member). I then upgraded to 2.2 - again as someone suggested - then used QuickPwn 2.2 Mac to jailbreak. At that point I downloaded BootNeuter 2.1 through Cydia, changed my bootloader to 4.6 and re-flashed the baseband.

    The current position is this; iPhone 2G, baseband 04.05.04_G Bootloader 4.6 (Neutered), FakeBlank off and "Unlocked", with firmware 2.2. But "No Service".

    I have a Vodafone SIM which works fine in a different phone and I've tried resetting through Settings > Reset > All Settings.

    No matter what I do I can't get any GSM service, the "No Service" message is displayed in my status bar. And yes there is Vodafone coverage in my area!

    Does anyone have any other suggestions that I can try?

    Cheers,

    Steve
    Last edited by briangriffin; 2009-03-25 at 09:20 PM. Reason: Automerged Doublepost

  2. #2
    Retired Moderator Poseidon79's Avatar
    Join Date
    Jan 2008
    Location
    Austin, TX
    Posts
    8,264
    Thanks
    819
    Thanked 1,681 Times in 1,159 Posts

    I'm a bit confused. If you insert a SIM card it will only see that carrier for which it is intended. For example.. .if I unlock my phone and put in an T-Mobile SIM.. and go to available networks.. it will ONLY see T-Mobile... and likewise for AT&T. How is it that you are referring to a "list" of available networks. If what you're saying is true what I would guess is that your SIM card is compatible with multiple networks but is restricted to the provider it was issued from. For example.. vodaphone has LCOKED that SIM for their network somehow so if you put that SIM in and try and choose a different carrier it will say "restricted". So you need to pick the provider from which your particular SIM was issued from.

  3. #3
    Hi,

    It's not so much what's displayed on the status bar that I'm referring to, which as you say is going to be "T-Mobile" for a T-Mobile SIM, "Vodafone" for Vodafone & so on.

    When I say "my phone can see a number of GSM networks..." I mean by visiting Settings > Carrier. In common with most (all?) GSM handsets this function will display a list of all network signals visible to the handset. Whether your SIM allows you to _join_ any of them is of course down to the SIM's capabilities (roaming etc. comes to mind).

    The point I was making was that the phone doesn't seem to have a hardware issue with its radio (it can see cellular networks) nor is there an absence of coverage (as it lists four or more operators as available; Orange, Vodafone, T-Mobile and O2).

    Cheers,

    Steve

  4. #4
    Livin the iPhone Life
    Join Date
    Aug 2008
    Location
    New York
    Posts
    1,024
    Thanks
    3
    Thanked 78 Times in 63 Posts

    Wait....Are you running baseband 4.X.X and trying to use a SIM that worked on an unlocked phone previously?

    If you upgraded your baseband on a 3G iPhone, there is no chance of you getting it back to one you can unlock.
    Last edited by boxxa; 2009-03-26 at 04:08 PM.

  5. #5
    Hi,

    In my desperation to find a solution to the "No Service" I'm now back on 1.1.4 (4A102) and BB 04.05.04_G.

    I have a number of SIMs to hand, none of which work with the phone but operate fine in other (non iPhone) handsets. All I ever get is "No Service".

    At one point today I even followed a tutorial on using KiPhone to erase my baseband entirely (under 1.1.4). At another stage I was on 2.x and grabbed Bootneuter through Cydia. It seemed to show me on 3.9 bootloader - could that be relevant? It (Bootneuter) hung moments afterward with a well documented "halo" once it determined my current settings.

    I think I now have every version of firmware and every iPhone tool for Mac & PC! If anyone can suggest trying something I'll gladly give it a go; ZiPhone, KiPhone, iBrickr, various versions of QuickPWN and Pwnage (Mac / PC)....

    I'd love to see a matrix which explained the relationship between baseband versions, bootloaders & firmware. i.e; "to have jailbroken and unlocked 2.2.1 on a 2G handset you need BL4.6 and BB 04.05.04_G" etc.

    At this stage though, any ideas would be gratefully received! :-)

    Regards,

    Steve

  6. #6
    Oh I forgot to add, I've just taken the SIM out of the "No Service" 2G and put it in another pwned 2G and it works fine.

    Which to my mind dispels any thought of a problems with the SIM or network coverage. BB on the working 2G is the same as the non-working: 04.05.04_G.

    Cheers,

    Steve

  7. #7
    Please tell me you resolved this

    I jailbreaked by 3GS and it worked for a week. I now have Network Restricted and exactly the same issue as you. Using a UK Vodafone Sim Card. I even went out and got a USIM as I was told that would fix it. Nope....

  8. #8
    Did you ever find a solution to this problem?

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •