Results 1 to 4 of 4

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: iPhone 2G 8GB won't take ANY firmware update!

  1. #1
    Default iPhone 2G 8GB won't take ANY firmware update!
    Hi!

    I have a 2G 8GB phone which simply refuses to accept any firmware (Apple or Custom generated), usually but not exclusively with an "Unknown Error (6)"

    My setup:

    \\ Mac OSX 10.5.6 (with USB DFU of installing iousbfamily315.4.1log - the 10.5.5 USB driver)
    \\ MacBook (Intel 2GHz)
    \\ PwnageTool 2.2.5
    \\ iTunes 8.0.2

    I've tried restoring firmware versions 2.0.2, 2.1, 2.2 and the latest 2.2.1. All end up with pretty much the same thing, the dreaded "The iPhone could not be restored. Unknown Error (6)". The phone won't even take a stock Apple 2.2.1 firmware by connecting it in restore mode, having it detected by iTunes and freshly downloading a 2.2.1 from Apple's servers.

    I've tried two different Apple USB cables, one from an iPod & one from a 3G iPhone. I've tried using different USB ports on the MacBook (not using a sync dock). I've made sure my iTunes > Device Support and iTunes > Software Updates folders are empty. I've tried restoring with the phone in DFU mode and in recovery mode.

    As you can see I've done my homework and applied just about every suggested fix I could find online. I'm now right out of ideas and the phone is stuck on the connect-to-iTuens screen.

    Can anyone suggest anything else I could try? I haven't removed & reinstalled iTunes or tried an earlier version, nor have I tried a different Mac or PC yet. Anyone have any direct experience of these options working?

    Thanks in advance,

    Steve

  2. #2
    1st be sure you succesfully put it into dfu mode.The screen must be blank.If so,then reinstall itunes or try to restore on a different computer...

  3. #3
    Hi,

    Definitely in DFU - screen is blank.

    I'll try reinstalling iTunes 8.0.2 (as it's easier than getting on to a fresh machine right now). Is there an accepted best-practice for removing & reinstalling iTunes on OSX or should simply trashing the application and reinstalling it be a thorough enough cleansing?

    I'm wondering whether there's something in /Libraary/iTunes (rather than ~user/Library/iTunes) which would be a good idea to remove.

    Thanks,

    Steve

    This really is a weird one.

    I've now had a chance to try applying firmware to the phone on a totally fresh (this time Windows) PC. Using WinPWN (latest version) I was encouraged to find the update process seeming to go well.

    I created a custom .ipsw, WinPwn took me through the DFU steps, saw Windows confirm it detected an iPhone in DFU mode and the firmware application process kicked off fine - even got the huge multi-coloured custom-boot-screen old style Apple logo on the phone's screen whilst the firmware was (seemingly) being applied.

    After about 20 minutes of the spinning indicator at the base of the iPhone's screen the process "completed" and the iPhone rebooted.

    Straight into Recovery Mode! :-)

    I'm totally lost now, having tried different cables, firmware versions (Apple & custom), different PCs (Mac & Windows), using iTunes, using Pwnage and WinPwn... The damned phone won't ever boot into anything but Recovery Mode.

    Aside from "will make a nice paperweight"... does anyone have any other suggestions?

    Cheers,

    Steve
    Last edited by briangriffin; 2009-02-23 at 02:37 PM. Reason: Automerged Doublepost

  4. #4
    Ok,try this
    Delete device support file
    Create a new custom fw with pwnage
    Put it into dfu mode
    If you get an error,close itunes&re-open it
    Then restore

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •