I wanted to orignally upgrade since jailbreak was working just fine on 1.1.4. what i didnt know is that most of the programs arent compatable. I need to either bring it back to 1.1.2 or take it down to 1.1.3. can some one help me out?