i just bought an Iphone ver 1.1.3 bootloader 4.6,i unlocked it .Everyhting works fine except the bluetooth,doesn't want to connect with other devices.My question is,do i need to downgrade my phone to 1.1.2 so i can get the bluetooth working.Any suggestion or help.Thanks in advance