Results 1 to 6 of 6

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Upgrade JB to 2.1, now WinSCP not working?

  1. #1
    Default Upgrade JB to 2.1, now WinSCP not working?
    I use iPhone Tunnel Suite and WinSCP to SSH via USB into my iPhone, as I have no WiFi at home. At least I did before upgrading to 2.1. Now I get "Network Error: Connection Refused" from WinSCP. Did any necessary settings change for 2.1? I'm trying to login using IP 127.0.0.1:22, with "root" and "alpine" as the pw. This worked fine with 2.0.2. Any advice? Thanks!

  2. #2
    Retired Moderator bhz1's Avatar
    Join Date
    Sep 2007
    Location
    Southeastern Pennsylvania
    Posts
    2,528
    Thanks
    92
    Thanked 361 Times in 271 Posts

    ihave been wrestling with this problem intermittently. I first discovered a workaround by reinstalling openssl and rebooting. However fir dome reason every time something was updated from Cydia ineeded to re do the workaround. Well today my fix didn't work at all. I think the problem has something to to with the mobile substrate. I uninstalled my 5 icon dock then reinstalled mobile substrate rebooted. Plugged into iTunes and let the of recognize my iPhone. Concurrently I recalled that at some point after upgrading to 2.1 I saw my wifi network was set to static. It had always been set to dhcp so I set it back thinking there was perhaps a reason it was changed I set it back to static snd so far so good.

  3. #3
    Wasn't working for me too right after i did the upgrade and jb. I kept trying and it finally let me in but it asked about my host key not matching and i just clicked update, however i had to switch the username to root and password to alpine instead of vise versa seemed to work for me bro gl tho.

  4. #4
    Figured it out. The OpenSSH that I had came from Cydia. Unistalled that, rebooted, installed OpenSSH from Installer, rebooted again, and everything went fine on WinSCP. Not sure what difference that made, maybe it just needed to try a clean install.

  5. #5
    Retired Moderator bhz1's Avatar
    Join Date
    Sep 2007
    Location
    Southeastern Pennsylvania
    Posts
    2,528
    Thanks
    92
    Thanked 361 Times in 271 Posts

    Quote Originally Posted by Freshtojeff View Post
    Wasn't working for me too right after i did the upgrade and jb. I kept trying and it finally let me in but it asked about my host key not matching and i just clicked update, however i had to switch the username to root and password to alpine instead of vise versa seemed to work for me bro gl tho.
    The user name should be "root" and teh password should be "alpine".

    I seem to have discovered that most of the problem is when I install or uninstall something from Cydia. It doesnt happen consistently though. Now today when I have the "no ssh" issue, I can get it to work by rebooting the phone.

    I never installed Installer with my latest jailbreak since I don't use it. but maybe I'll try to add it on and install Open SSH from it.

  6. #6
    iPhoneaholic theone77's Avatar
    Join Date
    Oct 2007
    Location
    PlaNeT Earth in the Middle Part
    Posts
    442
    Thanks
    47
    Thanked 276 Times in 112 Posts

    correct INSTALL OPENSSH again thru cydia. if u just want to copy and browse something use iphonebrowser, no wifi needed only cable but u cannot set permission
    DoNt ForGeT to Say "THanK You" using tHe THANKS ButToN if you found my post helpful

    Apple iPhoNe 3GS Factory Unlocked 3.1.2 All working flawlessly!!
    .

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •