Page 1 of 2 12 LastLast
Results 1 to 20 of 25

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Plz Help! Restoring Iphone 3g gets error 1002 when restoring firmware

  1. #1
    Default Plz Help! Restoring Iphone 3g gets error 1002 when restoring firmware
    I have been having problems with my Iphone 3g. It was jailbroken and one day just turned off and wouldn't restore again. I kept getting error 1604, and tried all the various solutions posted in these forums. My thoughts are that my baseband is somehow mismatched with my firmware. Now I have downloaded Itunes 8 and it almost completes the restore process. However, when it is "restoring firmware" it comes up with error 1002. What does this mean?

  2. #2
    Retired Moderator Poseidon79's Avatar
    Join Date
    Jan 2008
    Location
    Austin, TX
    Posts
    8,264
    Thanks
    819
    Thanked 1,681 Times in 1,159 Posts

    Are you restoring to a stock apple firmware or a custom pwn firmware? Either way make sure you are in DFU mode first.

  3. #3
    Yes I am definitely in DFU mode. I've tried both stock and custom firmware, and various versions of each.Any other suggestions? I'm just not sure what error 1002 means.

  4. #4
    Hey guys I'm having the same problem. I have a 3G 16GB. After getting the "error 1002" notice in Itunes 8, I just quickpwned it with 2.1 firmware and the phone did boot up, but now it displays the apple repair notice. Incoming/outgoing and wifi are disabled. I'm sure its not a hardware problem because the phone has never been dropped. Any advice would be greatly appreciated as well! Thanks!

  5. #5
    Perhaps it's an issues with Itunes 8? I've read a few people's woes with jailbroken iphones and iTunes 8 restoring...

  6. #6
    I tried to restore through Itunes 7.5 and then quickpwn, but I still get the same problem. I also downgraded to 2.0 and tried winpwn, but same problem again. I'm not sure if I should try to upgrade to 2.1 via Itunes.

  7. #7
    guys i ave the same problem here, iphone 3G tried restoring in DFU and other (cant remember the name now) mode but restore fails error1002. fresh download from the net from itunes 8.1. I had to go to srestore as the phone (not jailbrocken) went into a mode were it said repair needed cannot send or receive calls. So now my iphone is dead. Any ideas?I also wanted to ask- how do you ipwned your phone when in dfu mode? which software do i need? Maybe if i get it into a different error state something can work? Thanks in advance - Nick

  8. #8
    same problem here any updates

  9. #9
    Default Error 1002
    Same problem aswell
    iphone 3g restoring to v2.2 gives me an error code after it completes restore (1002). i can restart the phone it boots up and tells me that restore is required and that wifi and incoming and outgoing calls will not work.

    A couple places i have read about this issue on say its a baseband issue and you should upgrade it manually. is there anyone that can point me in the right direction?

  10. #10
    What's Jailbreak?
    Join Date
    Jul 2008
    Location
    Florida
    Posts
    3
    Thanks
    1
    Thanked 0 Times in 0 Posts

    yup i got this issue also any help would be awesome. my nephew bought this phone and was told all it needs was a restore and it does not wanna take. it keeps crapping out in both modes dfu and the other restore mode. not sure what was originally on the phone because it has been messed up since purchase.

  11. #11
    I need help on this issue too....

  12. #12
    Default Solution Found
    All:

    Posting this here as this is the first hit on google. Hopefully my fix works for others. Doing this from memory so the exact language used in the prompts is verbatim. Some background:

    My iPhone 3G running iOS 4.0.2 (never jailbroken) crashed unexpectedly one day. Got the "restore needed" prompt. Plugged into my computer and ran the restore process using iTunes. After NEARLY finishing and hitting the firmware portion of the restore process, iTunes stops and gave the dreaded "Error 1002". I read all over the internet that Error 1002 was always hardware related. While this may be the case SOMETIMES, 1002 is by no means a death knell so don't lose hope.

    What I did, fairly simple:

    1. Run the restore process. Close out of iTunes after you received the 1002 error.
    2. Download blackra1n: Blackra1n: Download Blackra1n
    3. Run blackra1n (follow instructions provided by those folks)
    3a. If you get the asl.dll error, follow these instructions: Error Blackra1n ASL.dll is not found | Blackra1n
    4. Run the restore process one last time. Running blackra1n should kick you out of the reboot process and the phone should restore successfully at this point.

    Good luck!

    Jin

  13. #13
    orangedays- i had the same problem as you the only difference was I was on 4.0.1 i got the 1002 error and i went through the process you provided but unfortunately blackra1n did not work. Is there any other way?

  14. #14
    Livin the iPhone Life jkmonkey's Avatar
    Join Date
    Mar 2010
    Location
    Upstate NY
    Posts
    1,433
    Thanks
    67
    Thanked 254 Times in 245 Posts

    Try using tinyumbrella to kick the phone out of recovery mode.

  15. #15
    tried that, it gets rid of the itunes logo and when trying to restore it gives a 1002 error...turned off the phone and held the power and home button but the phone does not go into dfu mode

  16. #16
    Default bricked phone
    i was running 3.1.3 with a jailbroken phone. the battery died and i plugged in my phone to the USB charger on my in dash CD player in my truck and left it. When I returned to my truck I realized that I had left the phone in direct sunlight, but the phone was not very hot to touch. I got the message your phone is unable to make calls or access internet. tried restarting phone and it just showed the apple for about a minute and rebooted itself so that it never left the apple screen. tried restoring through itunes and got error 23. Tried restore in DFU, got error 1002. ran blackra1n while doing DFU restore and got it to show the emergency call/restore needed connect to itunes screen. i plugged it back in, tried restoring, and now it says that there is no SIM card installed in my iphone and that i need to disconnect and insert one into it. so it just seems that i am going in circles here. any suggestions at this point? if not, i'm just going to go get another one.

    forgot to mention, i have a 3GS 16G

    also forgot to mention, swapped with girlfriend's SIM which works fine in her phone and her's as well did not work in my phone.

    ALSO when I tried to restore phone it installed 4.0 on there and i just read somewhere that if you run 3.1.3 and this happens it locks. any help is greatly appreciated!
    Last edited by Sativaman; 2010-09-01 at 07:23 AM. Reason: Automerged Doublepost

  17. #17
    Retired Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,996
    Thanks
    76
    Thanked 2,764 Times in 2,652 Posts

    You have a hardware problem , error 23 and error 1002 both are hardware issues. Sorry, i think you have to get a new one.

  18. #18
    I had the same issue and I had to take it to the apple store and they replaced it.

  19. #19
    Default [PROBLEM SOLVED] With iTunes 10 and iOS 4.1
    I had this problem. I tried using my Laptop with iTunes 9 and PC with iTunes 10. Tried Recovering in both DFU and Recovery Mode on both with firmwares 3.0, 3.1.2, 3.1.3, 4.0, and 4.0.2 but had no luck with any of them. (with the exception of 3.1.3 that removed wifi and bluetooth features...)


    Here's how I fixed this problem. Your iPhone is probably NOT dead!

    Please note the following instructions will revive your iPhone from recovery mode, but as 4.1 is the newest firmware it may not have jailbreak or unlock support right now. (or possibly ever) So this should only be used for AT&T users or people knowing they may not be able to unlock their phone after the process is completed.


    *I did all these steps without a SIM card in my phone.. Not sure if it makes a difference but if it doesn't work with it installed take it out and retry.

    1. Get the new version of iTunes (10)
    2. Connect to iTunes in DFU mode (or Recovery if that's what it will detect)
    3. Do NOT shift click recovery. Instead, select "restore and upgrade" (this will install iOS 4.1)
    4. This should successfully install without error! (It worked for me)
    5. Then feel free to use redsn0w 0.9.5 to jailbreak (remember to browse iOS 4.0 IPSW even though you have 4.1 installed)
    6. Insert SIM
    7. iPhone is at least functional with AT&T Sim. See elsewhere for jailbreak+unlock.

    - PseudoChris
    Last edited by [email protected]; 2010-09-19 at 11:19 PM.

  20. #20
    Default 1002 error
    guys dont waste time no one can fix 1002 error
    because this is 100% hardware issue
    digital base band needs to be replaced

    shortly will post gide to replace digital base band
    Last edited by prakashsirvee; 2010-12-12 at 01:13 PM. Reason: Automerged Doublepost

Page 1 of 2 12 LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •