Results 1 to 8 of 8

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Correct way to upgrade an unlocked ipsf iphone

  1. #1
    Default Correct way to upgrade an unlocked ipsf iphone
    hey everyone I'm a newbie so please go easy on me. I currently have an iPhone I purchased with firmware 1.1.1. I used ipsf to unlock/activate phone (on tmobile). I used the ipsf method to upgrade to 1.1.2 and would like to now upgrade to 1.1.3. I am looking for the best way and simpliest way to upgrade. Please include detailed instructions and anything I should be careful with. I have searched alot of forums and there are so many different people saying which way to upgrade but I haven't found much relating upgrading on a ipsf iPhone. Re ziphone method looks great but I have read different ways to use it but non pertaining to a ipsf unlocked phone. Please help I greatly appreciate it! Also can you let me know of any features that do not work with the upgrade ie google maps locate, etc etc

  2. #2
    I have an IPSF phone that's on 1.1.3 and 04.03.13_G baseband. Everything works.

    When the Gunlock came out I did it. Basically its a downgrade to 1.1.1, jailbreak, activate, octoprep, upgrade to 1.1.2, then do the soft upgrade to 1.1.3. It's a long process and I ended up with 1.1.3 and old baseband. I don't think you need to mess with that.

    When the ZiPhone method was released, I saw some other threads telling of IPSF phones getting to 1.1.3 AND 04.03.13_G baseband. It was confusing. BUT, most people agreed that if it went wrong, all you had to do was Restore in iTunes and try again.

    So,

    I used iTunes to UPGRADE my phone to 1.1.3 (this gives you the new baseband)

    I used ZiPhone -j -a (before the GUI was released) figuring that it didn't need to be unlocked again. Everything worked except I had no signal; wi-fi worked. So, I went ahead and ran it again with -u and it unlocked!

    I now have an IPSF 1.0.2 phone upgraded all the way to 1.1.3 with 04.03.13_G baseband. EVERYTHING works (maps locate me, everything - the new baseband was retained!).(I think this phone is getting tired of upgrading!)

    I don't see any reason why you can't use the GUI version 2.4.

    Windows: http://iclarified.com/entry/index.php?enid=667

    MAC: http://iclarified.com/entry/index.php?enid=675

    You might also enjoy Zibri's blog: http://www.ziphone.org/

    You should be happy that you have an IPSF phone. I am.

  3. #3
    Did you uninstall all your 3rd party apps before upgrading. I also noticed on the wiki for ziphone it noted no to do unlock if your iPhone has the old baseband and I noticed you said you did. Can your or someone please clarify


    Quote Originally Posted by sura View Post
    I have
    an IPSF phone that's on 1.1.3 and 04.03.13_G baseband. Everything works.

    When the Gunlock came out I did it. Basically its a downgrade to 1.1.1, jailbreak, activate, octoprep, upgrade to 1.1.2, then do the soft upgrade to 1.1.3. It's a long process and I ended up with 1.1.3 and old baseband. I don't think you need to mess with that.

    When the ZiPhone method was released, I saw some other threads telling of IPSF phones getting to 1.1.3 AND 04.03.13_G baseband. It was confusing. BUT, most people agreed that if it went wrong, all you had to do was Restore in iTunes and try again.

    So,

    I used iTunes to UPGRADE my phone to 1.1.3 (this gives you the new baseband)

    I used ZiPhone -j -a (before the GUI was released) figuring that it didn't need to be unlocked again. Everything worked except I had no signal; wi-fi worked. So, I went ahead and ran it again with -u and it unlocked!

    I now have an IPSF 1.0.2 phone upgraded all the way to 1.1.3 with 04.03.13_G baseband. EVERYTHING works (maps locate me, everything - the new baseband was retained!).(I think this phone is getting tired of upgrading!)

    I don't see any reason why you can't use the GUI version 2.4.

    Windows: http://iclarified.com/entry/index.php?enid=667

    MAC: http://iclarified.com/entry/index.php?enid=675

    You might also enjoy Zibri's blog: http://www.ziphone.org/

    You should be happy that you have an IPSF phone. I am.

  4. #4
    Did you uninstall all your 3rd party apps before upgrading. I also noticed on the wiki for ziphone it noted no to do unlock if your iPhone has the old baseband and I noticed you said you did. Can your or someone please clarify


    Quote Originally Posted by sura View Post
    I have
    an IPSF phone that's on 1.1.3 and 04.03.13_G baseband. Everything works.

    When the Gunlock came out I did it. Basically its a downgrade to 1.1.1, jailbreak, activate, octoprep, upgrade to 1.1.2, then do the soft upgrade to 1.1.3. It's a long process and I ended up with 1.1.3 and old baseband. I don't think you need to mess with that.

    When the ZiPhone method was released, I saw some other threads telling of IPSF phones getting to 1.1.3 AND 04.03.13_G baseband. It was confusing. BUT, most people agreed that if it went wrong, all you had to do was Restore in iTunes and try again.

    So,

    I used iTunes to UPGRADE my phone to 1.1.3 (this gives you the new baseband)

    I used ZiPhone -j -a (before the GUI was released) figuring that it didn't need to be unlocked again. Everything worked except I had no signal; wi-fi worked. So, I went ahead and ran it again with -u and it unlocked!

    I now have an IPSF 1.0.2 phone upgraded all the way to 1.1.3 with 04.03.13_G baseband. EVERYTHING works (maps locate me, everything - the new baseband was retained!).(I think this phone is getting tired of upgrading!)

    I don't see any reason why you can't use the GUI version 2.4.

    Windows: http://iclarified.com/entry/index.php?enid=667

    MAC: http://iclarified.com/entry/index.php?enid=675

    You might also enjoy Zibri's blog: http://www.ziphone.org/

    You should be happy that you have an IPSF phone. I am.

  5. #5
    Did you uninstall all your 3rd party apps before upgrading. I also noticed on the wiki for ziphone it noted no to do unlock if your iPhone has the old baseband and I noticed you said you did. Can your or someone please clarify


    Quote Originally Posted by sura View Post
    I have
    an IPSF phone that's on 1.1.3 and 04.03.13_G baseband. Everything works.

    When the Gunlock came out I did it. Basically its a downgrade to 1.1.1, jailbreak, activate, octoprep, upgrade to 1.1.2, then do the soft upgrade to 1.1.3. It's a long process and I ended up with 1.1.3 and old baseband. I don't think you need to mess with that.

    When the ZiPhone method was released, I saw some other threads telling of IPSF phones getting to 1.1.3 AND 04.03.13_G baseband. It was confusing. BUT, most people agreed that if it went wrong, all you had to do was Restore in iTunes and try again.

    So,

    I used iTunes to UPGRADE my phone to 1.1.3 (this gives you the new baseband)

    I used ZiPhone -j -a (before the GUI was released) figuring that it didn't need to be unlocked again. Everything worked except I had no signal; wi-fi worked. So, I went ahead and ran it again with -u and it unlocked!

    I now have an IPSF 1.0.2 phone upgraded all the way to 1.1.3 with 04.03.13_G baseband. EVERYTHING works (maps locate me, everything - the new baseband was retained!).(I think this phone is getting tired of upgrading!)

    I don't see any reason why you can't use the GUI version 2.4.

    Windows: http://iclarified.com/entry/index.php?enid=667

    MAC: http://iclarified.com/entry/index.php?enid=675

    You might also enjoy Zibri's blog: http://www.ziphone.org/

    You should be happy that you have an IPSF phone. I am.

  6. #6
    I think I did uninstall all the 3rd party apps for the first upgrades to 1.1.3.
    I also noticed on the wiki for ziphone it noted no to do unlock if your iPhone has the old baseband
    When you upgrade in iTunes, you get the new baseband.

    This is how I remember doing it. Not to say I haven't forgotten something. When I unlocked with Ziphone, I was expecting the baseband to be downgraded like on non-IPSF phones but it wasn't.

  7. #7
    Thank you for the help. I do still have a few unanswered new questions. I have heard that there is a signal issue when upgrading ipsf iPhones and a signal.app must be out in a plist file??? Not sure if I wrote that correct.

    Another question should I hit upgrade or put phone into dfu mode and do a restore to 1.1.3 from iTunes. Heard this is the best method but none of what I read was related to ipsf.


    Quote Originally Posted by sura View Post
    I think I did uninstall all the 3rd party apps for the first upgrades to 1.1.3.
    When you upgrade in iTunes, you get the new baseband.

    This is how I remember doing it. Not to say I haven't forgotten something. When I unlocked with Ziphone, I was expecting the baseband to be downgraded like on non-IPSF phones but it wasn't.

  8. #8

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •