Results 1 to 12 of 12

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Guide - WinPWN 2.5 Beta (step by step)

  1. #1
    Default Guide - WinPWN 2.5 Beta (step by step)
    Dev team's newest release is WinPWN 2.5 Beta. This jailbreaking tool gives you the ability to update your phone to 2.0.2 firmware while preserving your modem firmware for future unlocks. This means if you have not used itunes to update your phone since 2.0.0 (release firmware) then you are still running on 1.45 modem firmware which is what the dev team is trying to hack. Once it is hacked you will be able to unlock your phone. To check modem firmware click settings, general, about and scroll to modem firmware.

    This tutorial is done on a 3G unit which is locked to its carrier.

    Step 1.

    Download winpwn 2.5 beta from our application section here. Then, download the proper firmware from and dump it in to the same folder you downloaded your winpwn application to.

    2G 2.0.2 Firmware
    3G 2.0.2 Firmware

    Step 2.

    Start to install winpwn by double clicking winpwn-2.5-BETA 2 Setup.exe

    Step 3.

    Chose if you want a desktop shortcut or no and click next.

    Step 4.

    Chose the folder to install winpwn and select isntall.

    You should see the install process start.

    When complete press finish.

    Your software is now installed.
    Lets start the jailbreak process.

    Step 5.

    Select the headset or itouch you want to jailbreak.

    Step 6.

    Select the firmware you want to put on your device, in our case its 2.0.2

    Step 7.

    Select if you are using a official carrier, in our case its yes since we are using it on a 3 year contract.

    Step 8.

    Select if you want to use custom logos.

    We chose yes.

    You can browse or go with the defaults, we went with the defaults.
    Click next, you should see it start building the custom ipsw file.

    Step 9.

    Select if you need instruction to goto DFU mode.
    We chose yes.

    Step 10.

    Turn of your phone and connect it to usb.
    Then click thumbs up.

    Click Ok

    Step 11.

    Follow the onscreen instructions to put your phone into DFU mode.
    You should hear the usb sound from your computer when it boots to DFU.

    When it enters DFU mode you will see a confirmation screen from WinPWN

    Step 12.

    When you see the screen below launch itunes.

    Your itunes will throw this error.

    Click ok then while holding shift click restore. You should be prompted to select a file.

    Browse to "MY Documents" folder and select the custome ispw file. Our case its Custom-iPhone1,2_2.0.2_5C1_Restore.ipsw

    The restore process should start.

    When completed let it reactivate and you should be good to go, double check that your modem firmware is still the same.

    Full Article.

  2. #2
    Default Step 11
    How long does one have to wait (2g iPhone) at step 11 on that guide?

    "Please wait while your iPhone is being prepared to accept custom IPSWs."

    Like 20 minutes or something? ( itunes 7.7 / winpwn 2.5 / iPhone 2g upgrade to 2.0 or 2.0.1 ).

  3. #3
    Quote Originally Posted by highplains View Post
    How long does one have to wait (2g iPhone) at step 11 on that guide?

    "Please wait while your iPhone is being prepared to accept custom IPSWs."

    Like 20 minutes or something? ( itunes 7.7 / winpwn 2.5 / iPhone 2g upgrade to 2.0 or 2.0.1 ).
    I've waited much longer...
    Guess what?
    Nothing happens.

  4. #4
    Same,
    sooooo frustrating. I had to take the phone downtown and pay 20 bucks to get it fixed.

    I guess Ill wait for the next version of winpwn before i try again, I wonder how many people are having this problem?

    .. Im on XP sp2 btw.

    I also tried downgrading to iTunes 7.5

  5. #5
    all you need to do is put it into DFU mode only takes 20 seconds then it should start on its own and tell you that you've done dfu mode correcly

    hold both bottons for 10 seconds
    then hold round button additional 10 seconds while letting go of the top
    and viola you should be in dfu mode, keep holding the round button till you hear the usb sound of something connecting.

    you are using the right file for 2g correct ?
    Last edited by cadsii; 2008-09-02 at 09:09 PM. Reason: Automerged Doublepost

  6. #6
    I got it into dfu mode allright with the great little screenshot this winpwn has, it said i was in dfu mode and 'please wait'.

    I also, another time, kept holding the home button even after it said I was in dfu mode and to 'please wait' for like 5 min but nothing happened. Still could not get to the last screen.

    If i put my phone into DFU mode can I just put it back into normal mode if i dont want to flash? I really dont want to have it f up again and I have to get somone to fix it for me.

  7. #7
    yea just hold the 2 buttons again together then just the top one it should boot up... i dont get it, you CAN'T brick your phone you can always put it into DFU mode then recover so there is no need to go anywhere to fix it

  8. The Following User Says Thank You to cadsii For This Useful Post:

    highplains (2008-09-03)

  9. #8
    well, i had to fix it b/c it 'bugged out' one night and it would not go to the home screen, it just would stay in the phone screen(s).

    I thats when i tried winpwn and it would not get to the final screen ( it got stuck on the second to last screen where it tells you to wait).

    I think the problem is that I could not get a proper custom firmware image from winpwn.

    having said all that, I guess I could just find custom firmwares on the net already made and try flashing with that from iTunes right?

  10. #9
    yea you could i find that you need 512 mb in your pc to build the custom image

  11. #10
    If you are having trouble with winpwn, quickpwn gui 2.0.2 works just fine. I've used it on 3 phones and no issues at all.

  12. The Following User Says Thank You to enfurno For This Useful Post:

    highplains (2008-09-11)

  13. #11
    I just wanted to throw this is for anyone that's having problems upgrading, like the frozen progress bar that NEVER finishes. I was trying to update my old 1st Gen iphone from 1.1.4 to 2.0.2, and every time I tried, the progress bar would stop at about 80% and never finish. I tried re-booting, I tried everything over and over again. I was on an Alienware laptop with tons of resources, but couldn't figure out what was wrong. So, I was fixing my dads old DELL D600, and decided to try his laptop. It worked in minutes. So I know for a FACT that trying on a different PC really does work. Will that help everyone? No, but it might help those like myself that ran into this freezing progress var issue.

  14. The Following User Says Thank You to ronfin44 For This Useful Post:

    highplains (2008-09-11)

  15. #12
    wow man, thanks for the reply. That is odd. Such a bummer that there are issues liek this b/c if i could reflash my phone whenever I wanted to I would be playing with the phone and installing WAY more 3rd prty apps. thanks for the input man.

    As soon as the weather gets crappy im going to reinstall XP and try again, maybe that will help. I'll try quickpwn gui 2.0.2 first though, thanks for that suggestion.

    On top of everything else now, iTunes 8 mucks with the process now as well.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •