I dont mean to be a nuisance, and I know plenty of people have posted something similar to this, however, if someone could give me a definative answer, it would be much appreciated, I will then od my part and help others in my shoes once my problem is solved.

So i followed the guide for getting a jailbroken 1.1.3 phone with google maps working. I did the upgrade to 1.1.3 through itunes, then downgraded to 1.1.1 twice, jailbroke, went to 1.1.2, all the while getting the sim error. Now rather then use the guide to go about getting to 1.1.3, I used the official devteam jailbreak available via installer. I upgraded to the latest version of installer, and downloaded BSD 2.1. I went through the whole jailbreak and then the phone reset. When it did, I had maybe 6 of the usual 17 apple apps, as well as installer, as soon as I updated installer, the phone reset and then all my apps were gone. I had full service. I have a phone with bootloader 3.9. I downgraded my baseband and firmware and went back to 1.1.2. All is well now, however, I would like 1.1.3. Any reason why the jailbreak did this to me? Also, do you even think its worth going to 1.1.3? Or should i just stay at 1.1.2 and wait for the definitive, no soft jailbreak solution.

What solution can be provided that will leave me with a jailbroken 1.1.3 phone that has google maps running. I dont mind downgrading upgrading, blah blah blah, I am no noob at this, just dont feel that comfortable toying with terminal, an automated solution would work. Have a:

3.9 bootloader
1.1.2 jailbroken
8gb
ATT Service