i have OOB 1.1.1 then unlocked via ipsf. i want to try out ziphone and it asks to update to 1.1.3 via itunes. if this doesnt work out (for whatever reason) can i just downgrade back to 1.1.1 tehn update to 1.1.2 the ipsf way and be safe?