I bought an OTB 1.1.2 iPhone and I downgraded and jailbroke it then upgraded 1.1.2 still jailbroken. When 1.1.3 came out I upgraded and obviously was no longer jailbroken. I really miss all my apps and need to jailbreak again either on 1.1.2 or 1.1.3. I've probably spent over 20 hours with in the last week to get my iPhone jailbroken again and I haven't had any luck. I was able to jailbreak it in 1.1.3 but then iTunes didn't even have a spot where it says what my phone number is and I could not get it activated. So my question is.... Is it possible for me to have a jailbroken 1.1.2 or 1.1.3 phone? With a 1.1.2 OTB that has been upgraded to 1.1.3? I have OSX and Vista and XP. Some one please help!

Thanks,
James