Results 1 to 4 of 4

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Bootloader erased. How do I load 3.9 back on? Errors when I try.

  1. #1
    Default Bootloader erased. How do I load 3.9 back on? Errors when I try.
    Hi folks. I'm stuck but I think I'm in a decent position to fix it. I have a UK iPhone which was 1.1.2 OTB with 4.6 bootloader. I did get 3.9 bootloader onto it once but I was never able to get an IMEI working, so I thought I'd try again. Now I don't have ANY bootloader.

    I have BSD Subsystem and Mobile Terminal installed on the phone. I have put the following files into a subdirectory of /usr/bin and made all the programs executable:

    BOOT03.01_M2S1.fls
    BOOT03.08_M3S1.fls
    BOOT03.09_M3S2.fls
    ICE04.01.13_G.eep
    ICE04.01.13_G.fls
    ICE04.02.13_G.eep
    ICE04.02.13_G.fls
    ICE04.03.13_G.eep
    ICE04.03.13_G.fls
    bbupdater
    ienew
    ieraser
    iunew
    nor
    secpack
    secpack31206.bin
    secpack31408.bin
    secpack40213.bin
    secpack40313.bin
    testcode.bb

    I can run ieraser sucessfully, and ienew sucessfully. I can even follow ienew with iunew sucessfully by making the testpoint. But I get errors with everything else. Obviously I can copy any of those secpack*.bin files over the 'secpack' file but I don't know which is the right one. I'm also unsure what 'nor' file I should have since I've seen different versions floating around of different sizes.

    I've tried ./bbupdater -l BOOT03.09_M4S2.fls because I thought that would install bootloader 3.9 again, but it ends saying "Error: Failed to download .FLS: Could not verify downloaded image."

    When I try ./bbupdater -e with a *.eep file I get "Error: Failed to download .EEP: Expected checksum x got y".

    Can't get anything to stick so my baseband and bootloader are always empty! Hope someone can suggest the magic combination.

    Whoops - absolutely typical. After sweating over this for a day or so I suddenly found the answer through desperation: oddly I worked after I ran ienew *twice* in succession. I have no idea why this would be. The first time I completed quickly (and requested the next step) but I just ran it again on a whim. This time it took much longer and clocked through a whole bunch of addresses. I guess it did a more thorough erasure. I don't really understand. But whatever - after that ienew ran and I am back on bootloader 3.9 again! Every time I think I've bricked my phone there's a way out...somewhere. Are these iPhones indestructible or what? I'll leave this thread incase someone else gets the same problem.
    Last edited by Izzard; 2008-02-04 at 02:07 AM. Reason: Automerged Doublepost

  2. The Following User Says Thank You to Izzard For This Useful Post:

    ba_bang (2009-02-04)

  3. #2
    Can plz tell me where i can find these files.... my phone has no boot loader... it was 3.9

  4. #3
    What's Jailbreak?
    Join Date
    Jul 2008
    Location
    delhi INDIA
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts

    is there anyone who can fix my problem
    i update baseband but its stuck in middle and when i restor it the pop up comes
    that repair neeeded ..and my wifi bluetooth and GSM not working i dont know what to do
    plzzzzzzzzzzzzzzz help me gyus

  5. #4
    i'd use boot nueter and reflash the baseband... but i know that reflashing it back and forth from 3.9 to 4.6 can cause hardware failure gl hopefully someone with better technical skills can help you out if boot nueter wont work.. im pretty sure you can flash the baseband using bootnueters tool directly from Pwnage Tool(mac) or WinPwn(windows) hope that helps

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •