Im buying one in the next few days and want to use it on the t-mobile network. Now I see everything dealing with 1.1.2 and 1.1.1 but nothing to do if u buy the phone with 1.1.3 on it to begin with. can it be downgraded? im on a mac also so if yes is there a guide for this useing a mac? I did do a serach but couldnt find a direct answer to this issue. thanks all in advance.