from 1.1.3 to something lower that i can jailbreak? i made the mistake of upgrading i think i had 1.1.2 before and all of the youtube things dont work i tried iphuc and i get an error code of some sort from itune ANY help appreciated