Page 1 of 2 12 LastLast
Results 1 to 20 of 25

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: 1.1.3 timezone (and SMS/email timestamp sorting) fix

  1. #1
    What's Jailbreak?
    Join Date
    Dec 2007
    Posts
    5
    Thanks
    0
    Thanked 2 Times in 1 Post
    Default 1.1.3 timezone (and SMS/email timestamp sorting) fix
    It is easy. It really is.

    If you are experiencing weird issues with SMS and/or email sorting after upgrading to 1.1.3, this is for you. I've seen many complaints around the net on this issue and even Apple seem to struggle on it.

    My guess: this is a *real* bug Apple left out when released the update.

    SYMPTOMS: after upgrading to 1.1.3, when you receive a SMS the timestamp is wrong and therefore it's placed out of order in conversation.

    DETAIL: you don't live on the West Coast and all received SMSs have a fixed time offset. Guess what? It's what's between you and Cupertino.

    CAUSE: the timezone database in firmware 1.1.3 has wrong default permissions for user "mobile". After upgrading to 1.1.3 your timezone may default to Cupertino, especially if you had to rollback from Nate True's and downgrade to 1.1.1. You try and set it back to the right zone but system time doesn't change. Then you tune system time to your own and voilą, you created an offset between you and the system (which still believes it's Cupertino time) fooling the phone and yourself.

    SOLUTION: turn on WiFi on the iPhone, ssh yourself into the system and fix timezone database permission:

    chmod 777 /var/db/timezone

    Then enter Settings / Date&Time and change your timezone back and forth, you'll notice system time will immediately follow accordingly (that was NOT true before the fix). Set timezone to your own, correct system time to reflect your time and you're done.

    Kudos to kopernicus and Hawkman of hackint0sh forum who suggested this

  2. The Following 2 Users Say Thank You to ae303hf For This Useful Post:

    dnoc (2008-02-02), olyntho (2008-01-31)

  3. #2
    Doesn't work here. Still getting SMS out of order.
    Sydney, Australia
    If you received help, click on the Thanks button!


  4. #3
    same here!! problem doesn't get fix for me after the ssh command. sms still out of order!!! help!!

  5. #4
    iPhone? More like MyPhone cockyjeremy's Avatar
    Join Date
    Sep 2007
    Location
    huntington, wv
    Posts
    205
    Thanks
    3
    Thanked 8 Times in 7 Posts

    I've had this same problem since going to 1.1.3

    I'm currently on stock 1.1.3 with no Installer or anything. If this didn't work for the last two people.. any other ideas on how to fix it?

  6. #5
    Default Time Zone Fix
    Another fix for the Cupertino (default) time problem:

    Use WinSCP to connect to your iphone. Navigate to /var/db/timezone. Rename the shortcut 'localtime' to 'localtimeold' or something. Create a new shortcut called 'localtime' and point it to /usr/share/zoneinfo/<your timezone>

    In my case it is /usr/share/zoneinfo/Europe/London

    This fixes timezone problem and ordering of text messages!

    Ender

  7. #6
    Do I code Melbourne, Australia like this?

    /usr/share/zoneinfo/Australia/Melbourne

    UPDATE: I used the above code, but it only works initially. When looking at the conversation as it happens, the order is correct. But once I exit and go back to read the conversation, it's still out of order.

    Next...
    Last edited by truenorth; 2008-02-07 at 12:21 AM. Reason: Test results
    Sydney, Australia
    If you received help, click on the Thanks button!


  8. #7
    Default Time Fix
    Did you go back into your iphone settings and manually alter the time? When I applied this fix the time on the very top of my home screen showed the correct time but i still had to alter it in settings.

    Try that

  9. #8
    Just did, but no joy.
    Sydney, Australia
    If you received help, click on the Thanks button!


  10. #9
    i just did this on one of my iphones and it worked but did it on the second and the file wont stay mode 777 it just reverts to 755

    lil help?

  11. #10
    I have another problem here: permissions on /var/db/timezone are 777 and /var/db/timezone/localtime symlinks to /usr/share/zoneinfo/Brazil/East; however, because we are in DST, all incoming SMS are offset by 1 hour.

    Any ideas? DST here will be over next weekend, but I don't want to go through this same hassle next October.
    Quitting wastes efforts.

  12. #11
    iPhone? More like MyPhone
    Join Date
    Nov 2007
    Location
    Australia
    Posts
    120
    Thanks
    8
    Thanked 3 Times in 2 Posts

    I dunno if this works but my sms seem to be in order now..

    All I did was connect to my iphone using fugu (Mac program) opened up the command box and typed in chmod 777 /var/db/timezone (now I don't know if it did anything I'm not sure about this stuff)

    Then I went into my settings and changed my timezone setting to automatic.

    At first this didn't work, however when I went to work in the morning (I'd assume I was picking up the signal from a different tower) It started working.

    Everything is now in order when I am at home or at the office. So maybe this mod works you just need to switch between a tower to get it to reset the time..

    Can't clarify any of this but its worth a try..

  13. #12
    try to turn off the automatic update
    it works for me at least.

  14. #13
    Default solution?
    has anyone found a solution to this problem? all my world times are incorrect and i'm unable to adjust no matter what i do. anyone have any ideas?

  15. #14
    iPhone? More like MyPhone
    Join Date
    Sep 2007
    Location
    TX
    Posts
    278
    Thanks
    12
    Thanked 26 Times in 24 Posts

    omg someone has to know

  16. #15
    IT worked initially but when i closed the sms app and opened it again they were randomized

  17. #16
    This fixed my problem, thanks!

  18. #17
    Well, if only Text.app would check the iPhone current time to timestamp the messages instead of relying on the timestamp applied by the carrier network... then all messages would always be in the correct order.

    Any developer out there would try and make such a patch? I'd do it myself, but I'm kinda busy these days and I know you guys are much much more skilled than me at iPhone hacking.
    Last edited by Callae; 2008-02-20 at 01:12 PM. Reason: Typo
    Quitting wastes efforts.

  19. #18
    there's a fix for the timestamp issue if you add the source http://www.iphones.ru/r

    it says SMS fix and i used it on 1.1.4 and it works perfectly.

  20. The Following User Says Thank You to jbrandon For This Useful Post:

    chillypbear (2008-03-17)

  21. #19
    iPhone? More like MyPhone
    Join Date
    Dec 2007
    Location
    Toronto, Canada
    Posts
    142
    Thanks
    53
    Thanked 26 Times in 20 Posts

    Quote Originally Posted by jbrandon View Post
    there's a fix for the timestamp issue if you add the source http://www.iphones.ru/r

    it says SMS fix and i used it on 1.1.4 and it works perfectly.
    Thanks JBrandon!!! Works on 1.1.3 too!

  22. #20
    Default SMS recieved have wrong date/time
    I have recently upgraded to 1.1.3 using the Soft Upgrade in Installer
    I have experience Problems. I changed TimeZone to Toronto and it didn't fix it

Page 1 of 2 12 LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •