I was just wondering...

If I have a stock 1.1.1, can I just install OktoPrep and update to 1.1.2 and unlock using AnySim 1.2u???

Or do I need to upgrade it first to 1.1.2, downgrade back to 1.1.1, install OktoPrep then upgrade back to 1.1.2?

Thanks!