I have a jailbroken FW1.0 with AT&T. I used INdependence to do it and activate it. I want to upgrade to 1.0.2 and the 1.1.1 later in the furture since 1.0 is getting buggy...Dont know what to do need help thanks in advance!!