Results 1 to 5 of 5

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Help Needed

  1. #1
    Default Help Needed
    Just this morning, my iPhone hang and i did a hard restart. However the Apple logo showed up and did not get into the main menu.

    I went home and tried to restore it but was not successful. I used ZiPhone to restore to locked state but it was stuck and I had no choice but to unplug the phone out.

    Currently, I'm trying to restore it using DFU mode but still cannot. The iTunes window shows Waiting for iPhone... and continues forever.

    Hope you can help me with this. Thanks

  2. #2
    try to restore on a mac, or try a different usb, because you need to use a high speed usb port or it wont work.

  3. #3
    Thanks for your reply
    I've tried it on 2 computers both with USB 2.0.
    It seems that I have damage the baseband. Is there anything I could do to recover it?

  4. #4
    i think that there is another thread which tells you how to recover ur baseband, good luck

  5. #5
    I'm not sure if it's the problem with my baseband. I tried finding the threat but was still unable to solve my problem. Any other suggestions?

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •