I recently got stealthsim, and before i do any modification I was wondering if I need to be at 1.1.2 firmware to use it.