This combines a couple problems I've seen across the forums all at once

Here's the short version
My iPhone won't open Mail.app (crashes on launch) and is in 2.0 5A345 (unjailbroken)

Here's the long version
Awhile ago i pwned my iphone which jailbroke it but there were problems so i restored to 1.1.4, however mail.app wouldn't open. I ignored it because it didn't bother me that much. Then a week or so ago I upgraded to the latest 2.0 beta firmware then immediately realized mobileme required mail which was still broken. I found a solution, but it requires a jailbroken iPhone which can't be done in 2.0. So I found a way to downgrade here on the forums, however on a step where I'm supposed to try restoring 1.1.4 then get an error I get the wrong error (not the one I'm supposed to get, an unknown error) so I can't continue onto the next step.

Any help would be greatly appreciated. If there's any other information you need by all means ask.