Originally firmware version was 1.1.1
i upgraded during activation to 1.1.2


Here is what i am doing

1- Running ITUNES, shift + restore and downgrading to 1.1.1
2-Get the 1015 error. run Ibrick and chose downgrade to 1.0.2
3-following instruction within IBrick.. Run itunes Shift + restore and load up the 1.0.2 firmware
4-Itunes states that the restore failed, and I get a yellow triangle on my
phone. I choose the corresponding option in IBRICK
5-IBRICK does its thing then i chose free my phone. thereafter phones goes to recovery mode.. i then run ibrick and choose boot my phone.
6-i confirm the Firmware version is at 1.0.2
7-using Idemocracy i run apptapp
8-i upgrade (thru the iphone ) the installer. Then install thru the iphone BSD Subsystem and OpenSSH . Then using ibrick PXL
9-thru idemocracy i downgrade the baseband to 3.X
10- phone reboots...(first time around..everything was good..when i had
had to redo all the steps everything seems to go smoothly however i
was unable to make calls)
11- i then tried to, using itunes , upgade firmware to 1.1.1 by shift =restore option....this then fails after a minute or so and iphone back to recovery mode..
12-i attempt to run ibrick and gete red screen on phone and have to basically start over by restoring thru itunes..

so what am i missing.. i seem to be able to jailbreak the phone as i had the app install icon and was able to updates sources, install apps, etc...

howver when i try to update the firmware back to 1.1.1 i end up in recovery mode after a few moments

any assistance would be greatly appreciated.

Thanks