Results 1 to 4 of 4

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Need help upgrading Jailbroken 1.0.2 to latest firmware

  1. #1
    Default Need help upgrading Jailbroken 1.0.2 to latest firmware
    Hello all,

    I would like to thank you in advance for trying to help me out with this. When I got my iPhone, I installed installer.app in early September after Apple released the 1.0.2 firmware for the iPhone. I'm assuming that my iPhone was jailbroken during the process of installing the installer.app. I've not updated to a newer version of the firmware out of fear of bricking my iPhone. But now I'd like to get updated to the latest version of firmware and I've taken the past hour or so to look over the forums to figure it out but I think I'm more confused that before.

    More info... This is a US phone with AT&T running firmware verion 1.0.2 (1C28). The SIMM card is NOT unlocked as I'm not even remotely interested in doing that.

    I've read several topics about "virginizing" the iPhone in order to perform the upgrade, but I'm not exactly sure what to do and where to go from here.

    If anyone can provide me with instructions for safely updating my iPhone from a jailbroken 1.0.2, I would greatly appreciate the help.

    Thanks!

    Anyone?
    Last edited by BradM73; 2007-11-20 at 05:09 AM. Reason: Automerged Doublepost

  2. #2
    If you are still using your original at&t sim card and have never unlocked your phone, only used the installer.app then you can just simply upgrade your phone to 1.1.2 if you havent and you have unlocked your phone either through anysim or ipsf then it gets a little bit more complicated.
    if you have unlocked your phone add i.unlock.no as a source in installer.app and install the verginizer that matches your baseband once you have fully verginised use this method to get to a fully unlocked 1.1.2 phone.
    http://hackint0sh.org/forum/showthread.php?t=15567
    i have used the method from that thread personally and it does work. As i have said though if you have never unlocked and have only got installer.app on your phone click that update button in itunes dont worry, 1.1.2 is great.

    Just read more and your phone is still on at&t and has never been unlocked, thats great news you can simply just update your iphone nothing to worry about.

  3. #3
    Yea, I've never unlocked the SIMM card because I had planned to continue to use AT&T for my carrier since that's the only way to get full use of the iPhone features, but have just enjoyed the applications available under the installer app. The only thing I ever remember doing is just installing the installer.app program from the Nullriver site and that was it. I'm not sure if that jailbroke my phone or what. I guess I'll just try to update to the latest firmware and hope I don't get bricked. Wish me luck.

    Thanks again.

  4. #4
    don't upgrade to 1.1.2 yet, you need to upgrade to 1.1.1, visit jailbreakme.com and install installer app, install OktoPrep from installer app, then upgrade to 1.1.2. And follow any guide to jailbreak. Easier to jailbreak then and saves headaches.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •