Results 1 to 2 of 2

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.

Thread: Unable to access jarfile jailbreak.jar ?

  1. #1
    Default Unable to access jarfile jailbreak.jar ?
    I've just tried the 1.1.1 to 1.1.2 Jailbreak (on a Mac)

    On a Jailbroken 1.1.1 phone, I installed the OktoPrep app, then upgraded to 1.1.2.

    Following the Jailbreak instructions, I launced the osx application.

    I get the error: Unable to access jarfile jailbreak.jar

    I've researched and researched this issue, but have either come up with nothing or some waaay to advanced/brief "solutions."

    I tried running the osx app via terminal (as some suggested), but get the same error.

    Can someone kindly either give me a hint as to my next step, or point to to a detailed explanation?

    Thanks. I know the masters here hate this sort of post, but I have tried searching before posting...

    Well, I managed to get everything working (i.e. a jail-broken 1.1.2, AT&T Activated phone).

    Here's what I did:
    [1] From my 1.1.2 phone, downgraded to 1.1.1 (via iTunes Alt+Restore)
    [2] Went to to install the AppSnapp
    [3] From Installer, installed the OKtoPrep
    [4] Updated to 1.1.2 in iTunes

    Previously, when I tried running the 1.1.2 jailbreak osx application, I got stuck with the error "unable to access jarfilejailbreak.jar". So I did some more reading and searching and did the following to get it to work.

    [1] Moved the 1.1.2 Jailbreak folder to my desktop
    [2] Renamed it "1" (for simplicity sake)
    [3] In Terminal typed cd ~/Desktop/1 (to point Terminal to the correct folder)
    [4] Then in Terminal typed ./osx (to run the osx program)

    That got me past the "unable to access jarfile" part. Once the process completed, I was left with a Jailbroken 1.1.2 phone that can make phone calls...

    What a waste of 24 hours for an "upgrade" (1.1.1=>1.1.2) that does nothing for me (I don't need international keyboards and don't care what my battery charge is while in iTunes). I just can't stop tinkering....
    Last edited by Argelius; 2007-11-13 at 07:10 PM. Reason: Automerged Doublepost

  2. #2
    Default i found this
    "Ok, looks like I got it to work. Unfortunately, simply clicking the "osx" executable is not going to work. If you're not in Terminal, and not in the right Current Working Directory (CWD), that file is not going to find the JAR file it needs. What yall need to do this:

    Download and extract the file to your Desktop. It should extract to something called "1".

    Now, open Terminal, at the prompt, type: cd ~/Desktop/1

    This will put you in the "1" folder, and allow "osx" to see the JAR file (hint: If you type: pwd, you should see the path to the "1" folder).

    Now, execute "osx" by typing: ./osx

    You should see a lot of crazy **** go by for a WHILE, then it will reboot twice and you should be done. Now go learn some UNIX!"

    found this on tuaw i think

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts