Results 1 to 4 of 4

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: unkown ICCID & IMEI # = Repair Needed

  1. #1
    iPhone? More like MyPhone acaijr73's Avatar
    Join Date
    Sep 2007
    Location
    Bermuda
    Posts
    209
    Thanks
    9
    Thanked 28 Times in 16 Posts

    Default unkown ICCID & IMEI # = Repair Needed
    Ok ive unlocked about 15-30 iphones for people and last week i came upon this repair needed problem... it was a 1.1.1 firm ware iphone. i proceeded to do the downgrade to 1.0.2 and downgrade the baseband which went fine then did the normal app tapp and independence run then i upgraded to 1.1.1.. i proceeded to run independence and it jus hung there so i quit and tried 2wice more times with same result.. i then downgraded it to 1.0.2 and and did the activation so rather than try 1.1.1 upgrade again i went to unlock 1.0.2 and any sim said it unlocked it... i then went to restart and thats when the dreaded pop up came "Repair needed"......
    Has anybody had this happn to them? i tried restoring 1.1.1 and it locked in DFU mode i downgraded back to 1.0.2 and i can get it to the activation screen but i get the pop up.... I got ifuntastic to unshackle it so i could read the internal files and i noticed the /usr/bin files where missing which i assumed since it cant make calls so i tried taking the files from another 1.0.2 phone and putting them there to see if itll read but to no avail.. Is there any way i can restore this iphone to working order.....

    ** i noticed in the info screen on the activation screen there was the ICCID and IMEI unknown****
    1) 16Gig 1ST GEN IPHONES 3.0 Unlkd /PWND/BNeutered

    1) 16Gig 3G IPHONE BLK PWND, 3.1.2 F/Unlkd

    1) 32Gig 3G(s) IPHONE 3.1.2 F/Unlockd/Blackra1nd

  2. #2
    Just wondering if you got this fixed. I actually ran into the same problem and im looking for help. ibrickr doesnt do anything, i still get the error. error 1012, and 1011.

  3. #3

  4. #4
    Uhmm, really bad! I had this problem too.
    After unlock, now no phone, no sound, no wifi, no imei.....
    Restore with iTunes always error 1011, tried with 1.0, 1.0.2, 1.1.1 are the same.
    Flash with baseband updater always checksum error.
    Spent 4 days for play with it but still no luck.
    Seem no way to revive it, bricked!

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •