was wondering if its necesarry to use a fresh install of 1.0.2 firmware befor downgrading the base band.

I ask because my iPhone has got the the following installed:
nes emulator
DNS tools
BSD subsystem
installer
OpenSSH

my phone is not unlocked