Results 1 to 7 of 7

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: jailbroken iPhone, Edge on but no longer working consistently

  1. #1
    Default jailbroken iPhone, Edge on but no longer working consistently
    Hi,

    I'm an AT&T customer with a 1.1.2 OTB iphone. I've been running the phone all year, jailbroken with activation bypass (i.e. no iPhone-specific account). This means I have a "standard" media max internet plan, rather than the iPhone data plan.

    I started with 1.1.2 JB, then a couple months ago moved to 1.1.3, via Ziphone. I've never had any trouble with my Edge connection.

    Then the last two-three weeks, I keep losing Edge internet access.

    Specifically: The Edge icon is always present, but I'm usually unable to access internet functionality. Safari will popup "safari can't open the page because it can't find the server". Weather won't load, etc..

    If I Reset All Settings, it will fix the problem -- for a few minutes. Then my network access vanishes again. Sometimes I can Reset Network Settings, but it doesn't always fix the problem. Toggling Airplane Mode seems to help also.

    Because of this, I upgraded to 1.1.4 last night. I first used Ziphone (had some trouble due to my own fault), then iLiberty+. My phone is jailbreak + activate + unlock. In iTunes I set the device as a new phone (i.e. not use backup). And I'm having the same Edge problem!

    I have Cydia and its BSD subsystem. I removed SMB today, so the only apps on my phone now (outside of unix stuff) are Cydia and Installer. Still have the internet connectivity problem. Wifi always works for me though. And as I said above, resetting settings can temporarily fix my Edge internet access.

    I tried BootNeuter today to ensure I have 4.6BL running. I thought that fixed my problem, but my internet seemed to stop working again. *sigh*

    Any help is appreciated. Thanks!

  2. #2
    Retired Moderator Poseidon79's Avatar
    Join Date
    Jan 2008
    Location
    Austin, TX
    Posts
    8,264
    Thanks
    819
    Thanked 1,681 Times in 1,159 Posts

    What I would do is test your edge connections before you do the jailbreak. Restore the phone and plug into iTunes for activation and see if it has problems in the factory state. If so then it's not a jailbreak issue... it's a phone issue or network issue.

  3. #3
    Can that be done with the activation bypass? (Since I don't have a legitimately activated phone...)

    I've tried about everything I can do at this point: clean reinstalls of 1.1.3 and 1.1.4; I've tried both the 3.9 and 4.6 bootloaders; and last night, I tried the iLiberty+ edge/wifi/bt fix, which I believe reformats the baseband.

    Since I always have the Edge icon, I wonder if it's actually a problem with the network? I would think a physical problem with my antenna (or something) would mean the Edge icon would not show; or wifi would also fail at times.

    Just this morning, internet availability has worked, then not, then works now.

    It's frustrating, that's for sure.

    Thanks for the suggestion.

  4. #4
    I'm having the same problem on 1.1.1, without the activation hack (I'm on the iPhone plan). I usually just restart the phone to fix it.

    I haven't tried diggging into it much until now but I'm going to go through my recent installs and undo them. I also downloaded a lot of large mp3s with MobileCast so I'm wondering if it's some kind of data throttling. I'm hoping that if all else fails an update to the newest firmware would solve it.

  5. #5
    After the hours I've spent formatting and reflashing the heck out of my phone (*sigh*), without changing anything, I finally took a look at the AT&T Wireless forums.

    Several people there have posted from all around the U.S., and have had the same problems with Edge that I described above. This includes legit iPhone customers; and apparently it's not limited to the iPhone. But AT&T isn't admitting to any problem, from what people report back who've called customer service.

    So I guess Edge in the U.S. is wonky for random people this month.

  6. #6
    I'm also having a problem with my 1.1.4 firmware. I realized it after jailbreaking and activation using iLiberty+. I also have Cydia and Installer running..

  7. #7
    Default solved
    I seem to have solved my Edge problem by putting my sim card into my previous phone for a while.

    Surprisingly, I had to reset all of the internet settings in my old phone (an unlocked e61), because it wasn't working at first. After re-creating them, it worked fine. After using the old phone for 2-3 hours, I put the sim card back into the iPhone, and Edge has worked fine for me since.

    I'm theorizing that AT&T pushed some update to the sim that my iPhone hadn't accepted. And judging from forums including AT&T's own and Apple's, there were random phones that had the same problem, including legitimately activated ones.

    At any rate, that's how I solved my Edge internet problem, I hope someone else finds this useful.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •