Results 1 to 4 of 4

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.

Thread: Problem with iFuntastic 4.6.1 auto-jailbreak

  1. #1
    Default Problem with iFuntastic 4.6.1 auto-jailbreak
    I just used iFuntastic 4.6.1 to upgrade my iPhone (previously unshackled 1.0.2 firmware, though not unlocked) to an unshackled firmware 1.1.1, and everything seemed to go off without a hitch, with one minor exception...

    iFuntastic installed the, which I am supposed to use to reinstall all of the third-party apps onto the iPhone, but the version of the that iFuntastic installed is 2.63, and not the latest 3.x...I would obviously want to install version 3.x of the, as its a far more polished version of the application, and seems to be geared for use by people with an unshackled 1.1.1 firmware iPhone...

    Normally, such a task would obviously be done by simply opening the and letting it refresh its sources, at which point it would notify you of an updated version of the program. But for one reason or another, even after updating my iPhone's firmware via iFuntastic, the that iFuntastic installed seems to be picking up the old preferences settings from the that I had on my iPhone prior to my recent firmware upgrade (obvious from the fact that clicking on the 'uninstall' tab shows me a list of 'allegedly' installed programs, which does list all of the programs I previously had installed on the phone, but none of which are currently installed)...despite that, it still thinks they are installed and is showing them to me in the list in the uninstall tab...

    MOST IMPORTANTLY, its showing me that version 3.x of the is already installed (because I did have it installed on my unshackled 1.0.2 iphone prior to the iFuntastic upgrade)...and as a result of this, the is not recognizing that there is an upgraded version available, despite the fact that clicking the about tab tells me that I am running 2.63!!

    Anyone have any idea about how I can go about manually upgrading the on my iPhone so that I can use the 3.x release of the program, and how I can go about trashing the preferences file of the old installer so that it accurately tells me which programs I have installed?

    Any suggestions would be greatly appreciated... Thanks!

  2. #2
    have you tried uninstallin all the apps that it thinks are installed. then they should show up in the list of applications. install them and they should work.
    hope this helps!

  3. #3
    Quote Originally Posted by Portdogmc View Post
    have you tried uninstallin all the apps that it thinks are installed. then they should show up in the list of applications. install them and they should work.
    hope this helps!
    I tried doing that but as soon as I tried uninstalling the second app on the list "Dock" the uninstall process gave me a script error...

    More importantly though, what happens when I have to uninstall the itself...its not like I can do that and then go back into the program to update it ( wouldn't be on my phone any longer)....I have also just visited and downloaded the apptapp installer and tried to run it from my intel mac, and the first screen asks me to pick which version of the firmware I am choices are 1.0.0, 1.0.1, 1.0.2...and I am of course now using the 1.1.1 firmware as a result of my recent iFuntastic 4.6.1 update....

    Any thoughts on how to deal with this?

  4. #4
    go into var/root/library/installer than open localpackages.plist in a text ediot and just delete all the tables with the apps installed. that is the file that says wether you have something installed or not, so when u delete it out of there everyting will be good, you can even go asfar as taking that file off the phone totally, and it may put a new one there, I'm not sure about that though, so your best bet is to just edit it

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts