Results 1 to 10 of 10

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: 1.1.1 and SSH

  1. #1
    Default 1.1.1 and SSH
    I can ssh into the phone, but cannot using Cyberduck or Fugu. Is there another way to get Installer to my phone? I have searched and cannot find an answer. Every guide just assumes that if you can ssh in terminal, it will work in the other apps. I get an error that says "unexpected end of sftp stream" in Cyberduck and Fugu says connecting for a while and then just goes back to the previous screen.
    Last edited by xboxgod; 2007-10-14 at 04:48 AM.

  2. #2
    My iPhone is a Part of Me
    Join Date
    Jul 2007
    Location
    Davis, California
    Posts
    674
    Thanks
    21
    Thanked 83 Times in 74 Posts

    thats cause sftp won't work. use scp connection mode instead. and yes, terminal can install Installer.app... everything Cyberduck and Fugu does remotely on your phone can pretty much be done in Terminal..

  3. #3
    Thanks for your reply. I figured out how to do it with Terminal and got a lot of stuff back on there. SummerBoard is working fine with the new version. I am down to Ringtones now. I have gotten them to appear in the list, but no sound comes out when I select them. I have a couple ideas but I need an easier way to get files from the iPhone to my Mac. A couple of the guides say that you can use Cyberduck or Fugu once you install ssh, but I have had no luck. Did I read wrong? Is this possible yet?

  4. #4
    I've had the exact same problem using Cyberduck. I'm okay with using Terminal but hope there's an easy workaround for using an FTP program.

  5. #5
    Help I can't figure out how to get the installer on the phone in terminal. an can't connect via cyerduck either. someone please give me a guide.

  6. #6
    Guys, my guide here which differs somewhat from the Dev team guide but will definitely get you through a little more easily and explains in precise detail what to do in the terminal to get you up and running with installer, etc. if you can already ssh into your phone you can likely just start in the middle of my guide: http://modmyi.com/forums/showthread.php?t=9667

  7. #7
    Install OpenSSH via Installer, that will restore SFTP access. I'm not sure why the docs don't just have folks install this one originally...

  8. #8
    I have tried that, but it is still installed from before the upgrade and it just happens to be one of the apps that Installer says "Error during uninstall script execution" and won't let me uninstall. Is there a way to do it manually through terminal so that it will appear in the menu under Install?

  9. #9
    OK, if you remove /System/Library/LaunchDaemons/au.asn.ucc.matt.dropbear from the iPhone, that will keep the 'bad' ssh from starting up, and let the 'good' OpenSSH run without issues. Just tried it, works fine.
    Last edited by Jimbo; 2007-10-15 at 06:59 AM. Reason: Automerged Doublepost

  10. #10
    Quote Originally Posted by Jimbo View Post
    OK, if you remove /System/Library/LaunchDaemons/au.asn.ucc.matt.dropbear from the iPhone, that will keep the 'bad' ssh from starting up, and let the 'good' OpenSSH run without issues. Just tried it, works fine.
    Can you document step by step removal of dropbear? I find when I install OpenSSH and still have dropbear on the phone I get strange things happening. Actually it would be ideal if you could add the instructions for removing dropbear to this thread: http://modmyi.com/forums/showthread.php?t=9667 that way everything is in one place.
    Last edited by TheYoshi; 2007-10-15 at 03:56 PM. Reason: added

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •