so since the only way to insall the ipad baeband is through 0.9.6 rc16 redsn0w, i was wondering, and answer only if you know for sure. IF i use the 0.9.6 redsn0w point it to the 4.3.3 FW and tell it to only install ipad baseband on my 4.3.5 3gs......now this might work, or... it might leave the phone in recovery mode. Any thoughts??