Results 1 to 10 of 10

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: wifi doesn't disconnect when locked

  1. #1
    Default wifi doesn't disconnect when locked
    i have an iphone 3g with firmware 4.2.1 on it that has been running great. but for some reason, lately it will not disconnect from the wifi network when i lock it.

    usually after the phone is locked, the wifi will disconnect and the symbol goes away at the top. then, when i unlock, it will take 5-10 seconds to reconnect to wifi and for the symbol to reappear.

    now, the symbol is always there and it's causing my battery to drain very quickly... in just 8 hours its empty. not only is the symbol always there but i can continue to ping the iphone uninterrupted while it is locked.

    the same thing happens at my work wifi network, though i haven't made any changes to the networks and i have tried rebooting the routers. i also tried 'forgetting this network' in the iphone and then reconnecting.

  2. #2
    Livin the iPhone Life
    Join Date
    May 2008
    Posts
    8,021
    Thanks
    102
    Thanked 789 Times in 731 Posts

    Have you installed anything recently or changed a configuration of an existing app? WiFi will persist when locked and power applied if a connection is active. For example, an existing ssh session.

  3. #3
    Did you recently upgrade to iOS 4.0+? I believe with 4.0 they started the "persistent" wi-fi: How to disable the Persistent Wi-Fi feature in iOS4 Kirichkov.com

    There's a great program on Cydia called DePersistWifi that fixes this problem

  4. #4
    thanks. i have always had notifications off and push email off as well, though i double-checked and they are still off. at the end of that thread the author admits it wasn't an issue, and one of the commenters says persistent wifi was fixed in 4.1. i've been running 4.2.1 for about a month now and this issue only showed up a couple days ago.

    i don't believe there are any active connections, as i have checked the list of open connections in my router and the iphone's IP doesn't show up at all. even if i reboot the phone and don't start any apps, the wifi will still stay connected.

  5. #5
    Livin the iPhone Life
    Join Date
    May 2008
    Posts
    8,021
    Thanks
    102
    Thanked 789 Times in 731 Posts

    It looks like you've covered the bases. How about resetting network connections? Maybe that will reset everything to normalcy.

  6. #6
    Yeah i tried rebooting the router, and i've also tried the DePersistWifi app and it doesn't even work! i lock the phone and waited 5 mins, and i can still ping it. if i wake it up the wifi symbol is still there. no active connections in the router. i think it must be this POS iOS, but i don't want to restore the phone... i have several things installed from cydia and it's a pain to reinstall all of it, re-setup my SSH keys, etc......

  7. #7
    Livin the iPhone Life
    Join Date
    May 2008
    Posts
    8,021
    Thanks
    102
    Thanked 789 Times in 731 Posts

    I assume you tried settings / general / resets / reset network settings ?

  8. #8
    hmm, no sorry i didn't know you were talking about that. i just ran it. then i went back into wifi settings and connected to my network, locked the phone, waited a few minutes, and damned it's still staying connected!

  9. #9
    Livin the iPhone Life
    Join Date
    May 2008
    Posts
    8,021
    Thanks
    102
    Thanked 789 Times in 731 Posts

    Let is sit locked a few more min. The iPhone has sleep, sleep more, and deep sleep, or at least it used to. Maybe it will disconnect after a longer wait. If that doesn't work .... you know what's next

  10. #10
    yeah i let it sit overnight and it was still connected this morning. wish i knew wtf caused it. i installed SBSettings and setup a shortcut to turn on/off the wifi for now, not gonna waste my time restoring the phone over this crap....

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •