Results 1 to 2 of 2

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Static file links and apps crashing

  1. #1
    What's Jailbreak?
    Join Date
    Nov 2007
    Posts
    25
    Thanks
    1
    Thanked 2 Times in 1 Post
    Default Static file links and apps crashing
    Hello,

    I have successfully used this trick on my iphone4 and ipad2, but did not work on my ipod touch4 and would like to know if anyone can help me with figuring out why.

    Using a download program for videos (like Mercury Browser) would put the downloaded files in a directory /var/mobile/Applications/1F0D blah/Documents

    The video player programs (good player, wmv player) expects to have the videos in its own directory /var/mobile/Applications/0DE blah/Documents

    so either one has to move them there OR use the stupid Inbox copy with the open with command. Idiotic.

    So, what I did successfully is to move all the hidden files/directories from the Documents directory of the video player into the one of the Mercury browser, delete it then create a static link named Documents into the video player folder pointing to the one in the Mercury browser one.

    This trick worked great for the iPhone4 and iPad2 (fw 4.02 and 4.3) but did NOT for the iPod touch4 (fw 4.2.1) or Ipod touch 2g fw 3.1.3.

    Yes, I know that the folder names are different from device to device for the Applications subdirectories, I checked and just not copy blindly. I know that naming is case sensitive. I did do Unix system administration for a number of years.

    I did try to chmod 777 all the directories, used iFile and SSH'ed into it to check that the static link works. The app just crashes, but works fine if I unde the changes.

    Why would it work on some devices but not on the ipod touch 4 ?

    Thanks,
    Jesus will come and deliver the 5.0 Apple FW. Jailbreak soon after, just wait a "few days" more.

  2. #2
    What's Jailbreak?
    Join Date
    Nov 2007
    Posts
    25
    Thanks
    1
    Thanked 2 Times in 1 Post
    I found that on the devices that had issues with the static links actually a hard / directory link fixed the problem beautifully (use ln -d instead of ln -s <source> <link>).

    However, on older devices on FW 3.1.3 hard links are not permitted, so my iPodTouch4 works but not the iPodTouch2g.

    One confused step at a time.
    Jesus will come and deliver the 5.0 Apple FW. Jailbreak soon after, just wait a "few days" more.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •