hey there mmi! ok so im running a 3gs with 4.0.1 and the JBme break. i recently purhcased an app that i really need but that app needs to run on 4.1 or higher. i really dont want to re-break my phone and was wondering if there is way that i can get that app on my current firmware without upgrading to 4.3.3

next if i do upgrade to 4.3.3. will i need to take any steps prior to that or will i just lose my JB in the upgrade process?

if i cant, would i have to upgrade ideally to 4.3.3 and then re-break using redsnow?

thanks for any insight

btw how easy is the redsnow jb? seems fairly easy but im a jbme type of guy. easy...