Results 1 to 4 of 4

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Itunes Won't Restore!

  1. #1
    Default Itunes Won't Restore!
    Hey Guys, here is what i have

    iPhone 4, 4.3

    tried to JB but just got the Cydia White Icon that does work

    tried to Update to 4.3.3 but that won't work and got error (10)

    now it tells me i need to restore & update to new FW but when it tries it fails.

    I tried Shift Restore with ISPW from here on 4.3, no luck

    tried same thing with 4.3.3, no luck


    it's just stuck on the iTunes Screen


    Trying right now to JB with rc16 with 4.3, it is on pineapple screen but it will fail too.


    NEED HELP!!

    Thanks in Advance!

  2. #2
    If your on unthered then reboot your device
    If your on there'd then plug it in to the computer go on redsnow and press just boot thered and follow the instructions
    Hope I helped

  3. #3
    How do I know if I am tethered or not? I believed untethered. Will try , thnx

    nope, nothing

    after much trying i was able to get it to work.

    it was in restore mode, BUT i shut it off and FORCED it into restore and did an update from iTunes to 4.3.3 (can be JB'd) took a while but worked!!

    Thanks for those who helped!
    Last edited by PURE XTC; 2011-05-17 at 06:45 PM. Reason: Automerged Doublepost

  4. #4
    What's Jailbreak?
    Join Date
    May 2011
    Location
    Singapore
    Posts
    26
    Thanks
    10
    Thanked 5 Times in 3 Posts

    Might be hosts set to the cydia server, try getting tiny umbrella and disabling the cydia hosts

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •