Page 1 of 2 12 LastLast
Results 1 to 20 of 21

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: SMS messages has wrong date/time

  1. #1
    Unhappy SMS messages has wrong date/time
    My iPhone Text messages work strange.

    I got the first message at Sep 28, 10.30
    I wrote an answer immediately (no new timestamp for my green bubble).
    I got an answer in 2 minutes, and this gray bubble got timestamp separator line, but it show Sep 28, 11.32
    And the next 2 message, got good minutes but +1 hour.


    I am in European time zone (GMT+1).
    Timezone support ON, Automatic DateTime OFF, and set European time zone.

    But, first two message has good time, all the following was +1 hour... so it comes in the future...

    any idea? your phones makes it too? little strange.

  2. #2
    I am having this same problem. I am GMT-7 I think, and my messages are coming in 7 hours behind the actual time.

    Sending is OK, it is the received messages that come in with the sent time being somehow altered by the GMT +/- settings.

  3. #3
    colt4fan:
    how is your date/time setting under genereal?
    i mean timezone and timezone support...

    yesterday i test it, and the first few messsage (1-3) have correct time stamp, and then suddenly got wrong time, wrong time zone exactly.

    i will make a test: set time zone to GMT, and set the time for my location...

  4. #4
    Default sms message wrong timestamp
    i've tested it.

    I live in Hungary (GMT+1).
    My iphone's config was: timezone support ON, timezone Hungary +1.
    Everything is OK (call times, calendars, and others).

    But SMS work with +1 more hour.

    It seems, the sms message app get the system date (timezone shifted) than read the timezone info and SHIFT again.

    Now i use my phone in GMT timezone, and every timestamp work fine!!!

  5. #5
    Default Timestamps in SMS very confusing
    I'm in Toronto, and I managed i get the SMS timestamps correct by setting my timezone to Reykjavik time, but that broke e-mail timestamps. It seems there's no way to get these both working correctly, don't know exactly what the reason is...

  6. #6
    Default getting close to a solution
    OK, I'm trying to play around with the time zones now. I set it to GMT (which then changes your phone time, so you need to manually set that again). Got my bf to send me a message, and it came in as one hour ahead of my current time. Tried again one hour the wrong way, then again one hour in the right direction (Azores). Anyway, I didn't realize til now that you have to reset the local time with every time zone change, so the messages are coming in off still, but at least a lot closer to the actual time.

    I've exhausted the number of "unnecessary text messages" that my bf will send tonight, so I'm going to wait til tomorrow, when I have both of our iPhones, and I will fiddle with the settings, as well as check out whether it messes with email stamp.

    (Personally, I use gmail, but I use it through WiFi rather than through the "mail" icon.)

  7. #7
    I also have the same problem but strangely only sms from a certain provider only.

  8. #8
    I have the same problem. My incoming SMS texts are 7 hours behind, however, my outgoing SMS and all phone calls time stamps are all correct.

    I could change the timezone to what's 7 hours ahead (Monrovia or something) but that would then mess up the times of my outgoing and phone call times.

    Is this fixed in 1.1.1? Of course I'm stuck with 1.0.2 for the time being. I guess for now I could just do the math, but with a number as high as 7, I might have to use my fingers sometimes...

  9. #9
    iPhoneaholic
    Join Date
    Sep 2007
    Location
    Toronto, ON - Canada
    Posts
    302
    Thanks
    41
    Thanked 25 Times in 21 Posts

    Default SMS messages has wrong date/time
    Ok I think I just figured out a temp fix for this issue with the wrong timestamp!!!

    I just tested this and it works ... it has to do with the DST.. for some reason anyone that is in the EST. time zone from what I can gather gets this issue... now I've tried turning of the network time.. but for some reason the iphone still continues to display 4 hours behind.. so I got thinking .. If I changed my time zone to something that was GMT+5 would this fix the issue with the 1 hour for DST and nope... no go.. it really did just ad 4 more hours... so I figured it out... we need a timezone that doesn't have DST and is GMT+0

    so here you go.. try this... chose any of these time zones or cities i should say:

    I used Rabat, Morocco and tested with my G/F who also uses an iphone and we are both on Rogers in Canada.

    Ok so turn off automatic update... chose Morocco as the time zone and manually set the correct time and this should solve the in correct timestamp until a better solution is put together...

    Set Automatically = OFF
    Time Zone = Rabat, Morocco
    Set Date & Time = Manually

    Calendar Time Zone Support = OFF

    Lighter

    Let me know if this works and here is the list of places with no DST and GMT +0.


    Burkina Faso
    Bouvet Island
    Côte d'Ivoire
    The Gambia
    Ghana
    Greenland
    northeastern
    Danmarkshavn and surrounding area
    Guinea
    Guinea-Bissau
    Iceland
    Liberia
    Mali
    Mauritania
    Morocco
    Saint Helena (including Ascension Island and Tristan da Cunha)
    São Tomé and Príncipe
    Senegal
    Sierra Leone
    Togo
    Western Sahara


    Quote Originally Posted by 321estrellas View Post
    I have the same problem. My incoming SMS texts are 7 hours behind, however, my outgoing SMS and all phone calls time stamps are all correct.

    I could change the timezone to what's 7 hours ahead (Monrovia or something) but that would then mess up the times of my outgoing and phone call times.

    Is this fixed in 1.1.1? Of course I'm stuck with 1.0.2 for the time being. I guess for now I could just do the math, but with a number as high as 7, I might have to use my fingers sometimes...

  10. The Following User Says Thank You to lighter For This Useful Post:

    kc_kasey (2007-12-26)

  11. #10
    Livin the iPhone Life redcard's Avatar
    Join Date
    Oct 2007
    Location
    Scotchland
    Posts
    2,141
    Thanks
    8
    Thanked 204 Times in 184 Posts

    There's an easy fix for this. Have 'set automatically' to off, your time zone to where you are, time zone support on, and time zone again to where you are

  12. The Following User Says Thank You to redcard For This Useful Post:

    kc_kasey (2007-12-26)

  13. #11
    Quote Originally Posted by lighter View Post
    Ok I think I just figured out a temp fix for this issue with the wrong timestamp!!!

    I just tested this and it works ... it has to do with the DST.. for some reason anyone that is in the EST. time zone from what I can gather gets this issue... now I've tried turning of the network time.. but for some reason the iphone still continues to display 4 hours behind.. so I got thinking .. If I changed my time zone to something that was GMT+5 would this fix the issue with the 1 hour for DST and nope... no go.. it really did just ad 4 more hours... so I figured it out... we need a timezone that doesn't have DST and is GMT+0

    so here you go.. try this... chose any of these time zones or cities i should say:

    I used Rabat, Morocco and tested with my G/F who also uses an iphone and we are both on Rogers in Canada.

    Ok so turn off automatic update... chose Morocco as the time zone and manually set the correct time and this should solve the in correct timestamp until a better solution is put together...

    Set Automatically = OFF
    Time Zone = Rabat, Morocco
    Set Date & Time = Manually

    Calendar Time Zone Support = OFF

    Lighter

    Let me know if this works and here is the list of places with no DST and GMT +0.


    Burkina Faso
    Bouvet Island
    Côte d'Ivoire
    The Gambia
    Ghana
    Greenland
    northeastern
    Danmarkshavn and surrounding area
    Guinea
    Guinea-Bissau
    Iceland
    Liberia
    Mali
    Mauritania
    Morocco
    Saint Helena (including Ascension Island and Tristan da Cunha)
    São Tomé and Príncipe
    Senegal
    Sierra Leone
    Togo
    Western Sahara
    Lighter, that sounds like it'll work, but does it affect your email timestamp (like mentioned above)?
    If it doesn't, I'll give it a try.
    Cya,
    B.

  14. #12
    My iPhone is a Part of Me
    Join Date
    Jul 2007
    Location
    Davis, California
    Posts
    674
    Thanks
    21
    Thanked 83 Times in 74 Posts

    Quote Originally Posted by 321estrellas View Post
    Is this fixed in 1.1.1? Of course I'm stuck with 1.0.2 for the time being. I guess for now I could just do the math, but with a number as high as 7, I might have to use my fingers sometimes...
    Not fixed in 1.1.1....

  15. #13
    iPhoneaholic
    Join Date
    Sep 2007
    Location
    Toronto, ON - Canada
    Posts
    302
    Thanks
    41
    Thanked 25 Times in 21 Posts

    Default SMS messages has wrong date/time
    I believe it doesn't affect the email time stamp because its set to whatever time you have in the phone and automatic update is turned off... should work in theory doesn't hurt to try... I would test but I don't use email on my iphone...

    lighter

    Quote Originally Posted by Bailey4427 View Post
    Lighter, that sounds like it'll work, but does it affect your email timestamp (like mentioned above)?
    If it doesn't, I'll give it a try.
    If what you say was true.. this thread would not exist... I've tried what you are saying... and sorry no go with Rogers ... unless you are with Rogers in canada and I will eat my words and say sorry...

    lighter

    Quote Originally Posted by redcard View Post
    There's an easy fix for this. Have 'set automatically' to off, your time zone to where you are, time zone support on, and time zone again to where you are
    Last edited by lighter; 2007-10-17 at 06:34 AM. Reason: Automerged Doublepost

  16. #14
    I set mine basically the same as yours "lighter", but now I wish there was a way to fix the "world clock" in the phone. Sure, the text messages are WAY more important than the correct Vancouver world clock time, but...it'd be nice to have it all work properly.

    PS - I don't have my phone set to an of the non-DST cities. Just some place in Portugal. I don't think DST interferes with mine at all.

  17. #15
    iPhoneaholic
    Join Date
    Sep 2007
    Location
    Toronto, ON - Canada
    Posts
    302
    Thanks
    41
    Thanked 25 Times in 21 Posts

    Default SMS messages has wrong date/time
    Yeah I think I made a mistake in my math... =) I don't think the DST has an effect on it either... Yeah the world clock bothered me as well I wanted it working too... but truth fully.. I don't use it... it has something to do with the Rogers network... wait for the iphone to launch and see what happens it should fix any issues... hopefully!!! I'mma a dealer for them so if they don't fix it I'll start complaining =)

    lighter


    Quote Originally Posted by colt4fan View Post
    I set mine basically the same as yours "lighter", but now I wish there was a way to fix the "world clock" in the phone. Sure, the text messages are WAY more important than the correct Vancouver world clock time, but...it'd be nice to have it all work properly.

    PS - I don't have my phone set to an of the non-DST cities. Just some place in Portugal. I don't think DST interferes with mine at all.

  18. #16
    Quote Originally Posted by lighter View Post
    Let me know if this works and here is the list of places with no DST and GMT +0.
    Lighter, I'm in Montreal Canada with Rogers, and here's how I just got mine to work.

    Set Automaticaly : OFF
    Time Zone : Montreal
    Set Date & Time Manualy
    Time Zone Support : OFF

  19. The Following User Says Thank You to fragznet For This Useful Post:

    fidosam (2007-12-21)

  20. #17
    Think this is the same method as redcard , and it works!
    Date & Time
    Set Automatically : OFF
    Time Zone :Correct Timezone ( I used Melbourne, Australia)
    Set Date & Time :Correct Time

    Calendar
    Time Zone Support : ON
    Time Zone : Correct Timezone ( I used Melbourne, Australia)

    Everything is working as it is supposed to at present!
    Keep my fingers crossed as its been annoying the **** out of me!!!!!!!1

  21. #18
    Green Apple fidosam's Avatar
    Join Date
    Oct 2007
    Location
    Montreal, Quebec, Canada
    Posts
    82
    Thanks
    33
    Thanked 4 Times in 4 Posts

    Quote Originally Posted by fragznet View Post
    Lighter, I'm in Montreal Canada with Rogers, and here's how I just got mine to work.

    Set Automaticaly : OFF
    Time Zone : Montreal
    Set Date & Time Manualy
    Time Zone Support : OFF
    Finally!! Thank you so much it finally works

  22. #19
    What's Jailbreak?
    Join Date
    Dec 2007
    Posts
    4
    Thanks
    0
    Thanked 3 Times in 1 Post
    Time Stamp FIXED!!!!!!!OK
    1-Entrar en la carpeta (por SHH) /usr/share/zoneinfo/America, y luego de hacer respaldos en nuestra PC, borrar los archivos Buenos_Aires, o Caracas(o la ciudad que coorresponda), que se encuentran en la carpeta America.
    Si Ud no esta en America Busque en la carpeta de su continente.
    2-Resetear el iphone
    3-Colocar el horario adecuado en Settings–General–Date and time-coloco Time Zone: Caracas(Buenos Aires, o la ciudad que corresponda)—luego en Set date and time coloco la hora del momento en Caracas(o tu ciudad).
    Voila
    Y se acaba el problema de Hora(orden de los mensajes) en SMS y el de horarios verano inv en los relojes del Clock.


    Voila!!!}

    Saludos de eluquer



    1-open the folder (by Shh) /usr/share/zoneinfo/America(or your continent), and after making a back up on your PC, delete file Buenos_Aires or Caracas, or wherever you are(your city),located in the folder America(or in your continent, Europe, Africa, etc).

    2-Reset your iphone
    3-Put the correct time in Settings–General–Date and time-
    Time Zone: Caracas(Buenos Aires, or the correspondent city)—
    Then in Set date and time put the proper time for Caracas, Buenos Aires, etc(your city).

    Voila

    End the problem with time stamp, SMS time order, and incorrect DST times.

    Works perfect in: 1.1.3 an 1.1.4 (checked in 26 iphones)

    Best Regards from Buenos Aires, Argentina


    eluquer

    1-Entrar en la carpeta (por SHH) /usr/share/zoneinfo/America, y luego de hacer respaldos en nuestra PC, borrar los archivos Buenos_Aires, o Caracas(o la ciudad que coorresponda), que se encuentran en la carpeta America.
    Si Ud no esta en America Busque en la carpeta de su continente.
    2-Resetear el iphone
    3-Colocar el horario adecuado en Settings–General–Date and time-coloco Time Zone: Caracas(Buenos Aires, o la ciudad que corresponda)—luego en Set date and time coloco la hora del momento en Caracas(o tu ciudad).
    Voila
    Y se acaba el problema de Hora(orden de los mensajes) en SMS y el de horarios verano inv en los relojes del Clock.


    Voila!!!}

    Saludos de eluquer



    1-open the folder (by Shh) /usr/share/zoneinfo/America(or your continent), and after making a back up on your PC, delete file Buenos_Aires or Caracas, or wherever you are(your city),located in the folder America(or in your continent, Europe, Africa, etc).

    2-Reset your iphone
    3-Put the correct time in Settings–General–Date and time-
    Time Zone: Caracas(Buenos Aires, or the correspondent city)—
    Then in Set date and time put the proper time for Caracas, Buenos Aires, etc(your city).

    Voila

    End the problem with time stamp, SMS time order, and incorrect DST times.

    Works perfect in: 1.1.3 an 1.1.4 (checked in 26 iphones)

    Best Regards from Buenos Aires, Argentina


    eluquer

  23. #20
    Quote Originally Posted by jhembach View Post
    I'm in Toronto, and I managed i get the SMS timestamps correct by setting my timezone to Reykjavik time, but that broke e-mail timestamps. It seems there's no way to get these both working correctly, don't know exactly what the reason is...
    I live in Toronto too and I tried setting my time zone to Reykjavic, Iceland but nothign changed....

Page 1 of 2 12 LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •