Results 1 to 2 of 2

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: iPhone 3G will not Sync/Charge via USB

  1. #1
    Default iPhone 3G will not Sync/Charge via USB
    Hardware: iPhone 3G 8GB
    OS: iOS 4.1(8B117)
    Firmware: 05.14.02

    Issue: Phone will not charge or sync via USB connection with Macbook(OS X 10.5.8 and iTunes 10.1)

    More info: I just got this problem a few days back and I figured it was because of a bad USB cable, so I got a new one from the Apple Store and I'm still having the issue.

    First off, I went to the Apple Support page for iPhone not appearing in iTunes and did all the steps including removing and reinstalling iTunes and the issue still happens.

    Secondly, I tested both USB ports on my Macbook with other devices and they both work fine so the USB port is not the issue.

    Third, the phone charges fine from the wall outlet so the USB cable is not the problem.

    Fourth, not only does it charge from the wall, but it also charges through my Mophie JuicePack Air, so the dock connector should be ok, although I did have to clean it up pretty well yesterday with a flattened cue tip, rubbing alcohol and compressed air - I did try connecting the phone with the JuicePack via the USB on the computer and it still won't charge/sync through the computer.

    Worst of all, it acts like there's a "short" in the phone because sometimes when I connect it, the phone will chirp like it is connected and then immediately after it will chirp again and if I wiggle the phone end of the USB cable it'll sometimes show that it is charging, however, considering I haven't had this problem with the wall charging it shouldn't be a short in the phone and sounds to be software related.

    Finally, if I turn the phone off and plug it in to the computer the Apple logo appears and the phone powers on, so what is going on here and what can I do to fix this?

    Thanks in advance!

  2. #2
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    48,878
    Thanks
    8,108
    Thanked 17,646 Times in 8,026 Posts

    Sounds like something is wrong with your USB connector. If you have cleaned it and still nothing then you may need to replace it or check if your warranty covers it.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •