Results 1 to 9 of 9

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Camera Roll Issue

  1. #1
    Default Camera Roll Issue
    I have a jailbroken iP4 with an issue I've never run into before.

    I did a short video earlier today and now my photo library wants to rebuild w/o success.

    I am unable to open my photo album or camera now. Is there a fix w/o restoring? I synced to see if this would help bun no go!


    Sent from my iPhone using ModMyi

  2. #2
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    48,875
    Thanks
    8,108
    Thanked 17,645 Times in 8,025 Posts

    Use a usb file program like iphonebrowser and see if you can see what might have gone wrong with the DCIM camera folder. You may want to try deleting it and see if that helps your problem (copy it to your computer first just in case).

  3. The Following User Says Thank You to Simon For This Useful Post:

    SkyGuy5 (2010-11-10)

  4. #3
    that exact same thing happen to me (ip4) i was about to restore and rejailbreak but i tried to reset general setting in settings app and everything went back to normal i didnt need to restore u could try that as a last resort, it worked for me. i dont guaratee it will work on all device. do at your own risk...

  5. The Following User Says Thank You to vanki3ll For This Useful Post:

    SkyGuy5 (2010-11-10)

  6. #4
    Quote Originally Posted by x98car View Post
    Use a usb file program like iphonebrowser and see if you can see what might have gone wrong with the DCIM camera folder. You may want to try deleting it and see if that helps your problem (copy it to your computer first just in case).
    Did that already w/o luck and made sure to back up photos at the same time.

  7. #5
    Retired Moderator soulthoughts's Avatar
    Join Date
    Sep 2007
    Location
    Tacoma, WA
    Posts
    3,096
    Thanks
    333
    Thanked 603 Times in 506 Posts

    Did you check the permissions on that folder?

  8. #6
    Quote Originally Posted by vanki3ll View Post
    that exact same thing happen to me (ip4) i was about to restore and rejailbreak but i tried to reset general setting in settings app and everything went back to normal i didnt need to restore u could try that as a last resort, it worked for me. i dont guaratee it will work on all device. do at your own risk...
    Didn't work, but I deleted all but one photo to see if this helped. It quickly reset the library. Somehow the last video didn't take, but I was able to save it to a sub folder.

    This is what I love about mmi. You guys are quick and friendly!

  9. #7
    oh sorry to hear that bro, i just got lucky i guess..

  10. #8
    Quote Originally Posted by soulthoughts View Post
    Did you check the permissions on that folder?
    What permissions and where?

  11. #9
    Retired Moderator soulthoughts's Avatar
    Join Date
    Sep 2007
    Location
    Tacoma, WA
    Posts
    3,096
    Thanks
    333
    Thanked 603 Times in 506 Posts

    Every folder/file on a computer has 'permissions.' This determines if the file can read/write/execute. It's the same on our phones. If the permissions aren't set correctly, an app can crash.

    Using winscp or any other filebrowsing app that lets you set permissions go to the DCIM folder. I'm assuming that's the problem folder. On a 3GS the path is:

    /var/mobile/Media/DCIM

    Right click on the folder (usually) and set the permissions to 750. That's how my DCIM folder is set. See attachment.
    Attached Thumbnails Attached Thumbnails -permissions.png  

  12. The Following User Says Thank You to soulthoughts For This Useful Post:

    SkyGuy5 (2010-11-15)

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •