Page 1 of 2 12 LastLast
Results 1 to 20 of 25

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Wifi issues iPhone 4 on 4.0.1

  1. #1
    Default Wifi issues iPhone 4 on 4.0.1
    The last few days my phone has not been connecting to my wireless router at home. In wifi settings it show my network and shows I'm successfully connected to it...but when click the arrow for details the page is blank or sometimes show a IP address that is incorrect. When I go to check the wifi address in SBSettings it is really messed up. I have no problems connecting to other people's/business' wifi. My phone is only doing this with my home network. My laptop works perfectly normal. Also, my iPhone has worked over wifi perfectly fine until now. Is this a phone problem, a router issue? I've already tried "forget network" and then "reset network settings" and connecting to wifi again. I tried unplugging power from the modem & router and powering them back on, even reset my router. That worked for a day and now I'm back where I started. Very frustrating! Any suggestions???
    Attached Thumbnails Attached Thumbnails -imageuploadedbymodmyi.jpg  

  2. #2
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    48,875
    Thanks
    8,108
    Thanked 17,645 Times in 8,025 Posts

    Sounds like it may be a router problem. For some reason you may be getting a bad ip address. This has happened to be a few times with a cisco router I had. Rebooting it usually fixed it. If you keep getting the issue coming back you may need to see if your router needs an update.

  3. #3
    I was thinking it has to be something with the router. My laptop connects o wifi, though, even when my phone won't. Good idea on checkin for the router update..I'll try it. Thanks.

  4. #4
    I unplugged the router and modem, waited about 2 minutes then plugged the power cord back to the modem, waited another minute and plugged the power cord back into the router. It's only been a day, but so far it's working as it should!

  5. #5

  6. #6
    The problem is back. Any ideas as to what is causing this? My pc and laptop don't have this issue.

  7. #7
    The problem is back.

  8. #8
    "Dennisls111" thanks for repeating what I said.

    Now, back to my issue...if I power down the router and plug it back it my iphone connects and the wifi at my home works. But, the connection doesn't keep. I had no issues for months so I'm not sure why it's suddenly doing this. Also, pulled out old iPhone 3G and had the same thing...so I think my phone is fine, but there's an issue with my router or Comcast. If it's the router, I don't understand why this only affectsy phone and not my laptop.

  9. #9
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    48,875
    Thanks
    8,108
    Thanked 17,645 Times in 8,025 Posts

    Quote Originally Posted by Nunya22 View Post
    The problem is back. Any ideas as to what is causing this? My pc and laptop don't have this issue.
    Not sure sorry, but pretty sure it is your router, not sure why it only affects your phone though.

    Quote Originally Posted by dennisls111 View Post
    The problem is back.
    What are you doing? This is the second thread I have seen you in just saying something stupid.
    Last edited by Simon; 2010-11-08 at 01:33 PM. Reason: Automerged Doublepost

  10. #10
    I know, wtf! People come here for advice, help and knowledge. Most people seem very helpful.."dennis" seems like an @ss

  11. #11
    iPhoneaholic marxus79's Avatar
    Join Date
    Nov 2010
    Location
    United Kingdom
    Posts
    335
    Thanks
    39
    Thanked 79 Times in 39 Posts

    Few days ago i had the same problem, i could connect to the network but could not use the internet, what i did very simple, renew lease > forget network and reconnect, that solved my problem. Does your iphone ip address start with 169.

  12. #12
    My iphone IP starts with 192. I'll give that a try, thanks!

  13. #13
    Turned ony phone this morning and it won't connect to my home network again. I just tried "renew lease", forget network and re-connecting, but it didn't make any difference.

  14. #14
    Quote Originally Posted by marxus79 View Post
    Few days ago i had the same problem, i could connect to the network but could not use the internet, what i did very simple, renew lease > forget network and reconnect, that solved my problem. Does your iphone ip address start with 169.
    After I did renew lease my phone does have a 169 IP address now.

  15. #15
    iPhoneaholic marxus79's Avatar
    Join Date
    Nov 2010
    Location
    United Kingdom
    Posts
    335
    Thanks
    39
    Thanked 79 Times in 39 Posts

    169 is not good. , should start with 192, is your router firmware up todate?

  16. #16
    Superbad Modder-ator Simon's Avatar
    Join Date
    Nov 2007
    Location
    Bermuda
    Posts
    48,875
    Thanks
    8,108
    Thanked 17,645 Times in 8,025 Posts

    Ya mine was having that same issue where the ip started with 169. I did a update to the router and have been fine since.

  17. #17
    It's been working for 2 days now. If it stops working I'll try resetting the router and let you know. Thanks for the input!

  18. #18
    I was having the same problem and after searching through this forum and reading a few posts, I realized my problem was user error. (isnt it almost always??!) Anyway, I'm posting this here in case anyone else happens to have made the same mistake:
    My phone was being kicked off my home router because I had set up MAC address filter on the router when I originally installed it. duh. So after I added my new iPhone's MAC addie in the router's interface, everything was gravy, no more problems

  19. #19
    ok i have an ipoid touch 2g on 3.0 and im having this problem. my ip is 169.xxx.xxx.xxx with sibnet mask 255.255.0.0 a week ago my wifi worked fine and was 192.xxx.x.x and there were no problems with it. ive tried all the solutions here + restart + forget network+ reste network setting. i dont want to restore. any help?

  20. #20

Page 1 of 2 12 LastLast
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •