Results 1 to 12 of 12

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: SSH problem with 4.1

  1. #1
    Default SSH problem with 4.1
    I am not sure why nothing is working, but I am unable to ssh into my phone it just wont connect, I've even tried mapping the drive through I think I tried quickoffice, it still wouldn't connect. I also tried iFiles web server and that would not connect.

    I am connected to the same wifi, I have openssh installed any ideas why this is happening?

    ~Tim

    If I have helped you then thank me.

  2. #2
    did you reboot your device?

  3. #3
    Retired Moderator iYeow's Avatar
    Join Date
    Feb 2008
    Location
    Vancouver, Canada
    Posts
    13,996
    Thanks
    76
    Thanked 2,764 Times in 2,652 Posts

    You have to install mobileterminal too. Then type ssh [email protected] ( this is your ip address on your phone of your router)
    Wait.& wait. until the key is generated.
    Then type Yes
    Then type Alpine
    Then type passwd
    Key in your new password : xxxxxx
    Retype again : xxxxxx
    Now you can ssh into your iphone.


    You can use WinScp to browse your files.
    Last edited by iYeow; 2010-10-12 at 09:42 PM.

  4. #4
    Terminal doesn't seem to want to work on 4.1, also is this something new? I never had to do this on 3.1.2, 3.1.3, or 4.0.1 on my 3GS

    ~Tim

    Edit: I have done those things on mobileterminal and my winscp still fails to connect.

    ~Tim
    Last edited by tjb5099; 2010-10-12 at 02:51 PM. Reason: Automerged Doublepost

    If I have helped you then thank me.

  5. #5
    tjb - I have same problem with SSH... but iFiles web server
    works fine. I think there is a problem with OpenSSH @ 4.1...

    stable version of mobileterminal won't work under OS 4.1.
    You can find beta version on other repos than modmyi/bigboss
    (ie. XSellize repo) - it works perfect.

  6. #6
    What are you using to connect and what is the exact error message displayed? Do you have WinSCP? Can you ping your iphone from your PC?

  7. #7
    What are you using to connect
    PuTTy, WinSSH, WinSCP, Telnet - I've tried everything...
    and what is the exact error message displayed?
    "connection was unexpectedly closed by remote server" or similar
    Do you have WinSCP?
    yes I have
    Can you ping your iphone from your PC?
    yes I can (and there is no problem to connect iFile web server)

    Anyway - I've just solved the problem, but I don't know what exactly was wrong [I reinstalled OpenSSH and reboot device several times, finally I installed BigBoss Recommended Tools - an it magically started to work]

  8. #8
    i have also a problem with the combination of iphone4, 4.1, greenpoison.
    i've installed openssh and mobileterminal,.
    mobileterminal just exits on start.
    i've de-installed both more times. but nothing.
    no connection from pc with putte possible.

    i have no idea whats wrong.

  9. #9
    OpenSSH is having some problems here too, since the 4.1 upgrade.

    I have managed to install mobile terminal, using the beta.

  10. #10
    Sorry to hear that guys im on 4.1 with it running great

  11. #11
    ok, i have now after more reinstalls a connection with putty...
    but the mobile terminal is everytime just quitting.
    maybe there's a new version in near future...

  12. #12
    same problem here. I think the issue is with some compatibility of openssh with IOS 4.1.
    To make ssh work, you need to reinstall it every single time and ssh into your phone right away other wise the same problems starts. After a reboot the ssh will not come back also.....I have restored and JB my iphone4 4.1 twice but this problems remains...

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •