if it doesn't work immediately then try:
1. reset network settings.
2. enable direct flag in the options for facetime

that's worked on the few I've tried.
enjoy.
(i got this info from Saoirse1916 elsewhere)