Results 1 to 2 of 2

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Chinese iPhone 4 locked to Chinese-language maps

  1. #1
    Default Chinese iPhone 4 locked to Chinese-language maps
    These two blog posts detail the problem:

    Ogle Earth: Beware: Chinese iPhone 4 comes with a crippled Maps app
    Ogle Earth: Chinese iPhone 4: Curious Google search results (+ more crippled maps)

    And some more discussion on Shanghai Expat

    In short, iPhone 4 made for the mainland China market (Hong Kong excluded) are locked to using the Chinese language maps in the maps app.

    How can we get around it now that Limera1n jailbreak is available?

    I've tried putting it into DFU then restoring from the 4.1 IPSW that I downloaded from Apple. Since the IPSWs are not country-specific, I would guess the code is written to check that if the phone is made for China and then to only load the maps for China. Google maintains ditu.google.com (ditu is Chinese for map) that appears to be the same map that is showing up on the phone, so it's likely the phone is accessing ditu.google.com instead of maps.google.com.

    Thanks in advance.

  2. #2
    I've made some progress on this. Using Paros to sniff the traffic, it appears that my iPhone uses google.cn for maps data. In Paros, I set up a filter to change HTTP request headers of "google.cn" to "google.com" and now the maps is showing English.

    I tried setting up entries in /etc/hosts to point google.cn to google.com's IP but this didn't seem to work. I think Google checks the requests headers and if it's .cn it gives the Chinese version, and .com the global version.

    Do you think it's possible to hack the iPhone somehow to change the HTTP request headers?

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •