Results 1 to 12 of 12

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Unable to Delete Apps

  1. #1
    Default Unable to Delete Apps
    Hey guys, I hope this thread is in the right spot.

    I've been having this problem with my phone since I first jailbroke it. I'm on iOS 4.0.1 with an iPhone 4. When I first jailbroke it I realized a bit later that I was unable to delete any apps I downloaded from the AppStore or Cydia (or anywhere else for that matter).

    I messed around with some permissions and couldn't figure it out. Unfortunately I messed around with too many permissions and ended up having to restore. I started fresh and ended up with the same problem. I hit the "X" to delete an app and nothing ever happens.

    I've been working around this by just unchecking the apps I want gone in iTunes and then syncing, but that's a little annoying, and I don't want to have to keep a folder on my phone called "Trash" anymore.

    Anyone have any suggestions?

  2. #2
    Get cydelete in cydia,it will delete cydia apps just like the x in spring board.Hope this helps,
    1Slyguy

  3. #3
    Thank you very much for the speedy reply. I'm sorry, I think I need to clarify a bit.

    I cannot delete any apps, including the ones downloaded form the Apple AppStore. I do have Cydelete installed on my phone and cannot delete those with the "x" either.

  4. #4
    Are you sure you reinstalled cydelete after restoring?The restore should of fixed all the permission changes.If you did then I cant think of anything else.Someone else might be able to help you.

  5. #5
    Yes. I started from square one with a fresh reinstall. Cydelete is installed, but that's only part of the problem... I cannot delete apps that I've downloaded from Apple's AppStore either, not just cydia apps.

  6. #6
    When you did the restore was it as a new device?If not try that your back up could be bad.

  7. #7
    Yes, as I mentioned in my first post, I started with a fresh configuration. It worked for a bit until I started installing my apps again. I'm sure one of them messes with some sort of permissions. I just don't know which one.

    I'm hoping someone else has had this problem and has figured out the solution.

  8. #8
    Default Can't close or remove apps
    Make sure if you have iBye installed that you haven't enable security and it's off. You can check under security->app managers ->appstore app data
    Make sure enable security is off.

  9. #9
    I am using an iPhone 4 and an iPad 2. I want to remove apps from the devices as well as the cloud list. (Not on this i***). Help!

  10. #10
    Quote Originally Posted by steonial View Post
    I am using an iPhone 4 and an iPad 2. I want to remove apps from the devices as well as the cloud list. (Not on this i***). Help!
    You can't remove them from iCloud. Just delete them from the device

  11. #11
    I was also facing this problem but after reading this post my problem is solved. Thanks for sharing such a useful information.

  12. #12
    I took the following steps to delete apps on iPhone permanently from my iTunes library. I use a MacBook Air and iTunes 11.0.04:

    Open iTunes
    Go to the Library drop down box
    Select Apps
    Click on individual app, press delete and hit enter
    Confirm decision
    Read more about iPhone Data Eraser here.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •