Results 1 to 3 of 3

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: iPhone 3GS won't restore to ANY firmware - help?

  1. #1
    Exclamation iPhone 3GS won't restore to ANY firmware - help?

    Hey, I was hoping someone could help me out with this.

    I recently bought an iPhone 3GS from someone who smashed their screen for cheap. I bought & installed the replacement screen and everything is ready to go except I cant seem to restore it!

    Here are the details, i hope i can get some help please

    - phone starts up in DFU mode
    - The 3GS was NOT jailbroken and had the 3.1 firmware i believe.
    - each time i try to restore it on iTunes, it says its not eligible for this firmware version.
    - I've tried it on two different computers (Windows)
    - I've tried it on both iTunes 9.0 and 10
    - I've tried downloading every firmware version after 3.0 to restore it manually in itunes (3.1.3, 4.0, 4.1 for 3GS) - same message about being ineligible
    - I've tried different USB cords, computers, and charging it for long enough


    -> I've done my research and still cant get my head around it... I understand that iPhone stopped signing downgrades but in this case it wont let me restore to anything!
    - I'm certain the phone is not damaged internally

    Anyone have better experience with this & know what's going on ?

    Thanks in advance.

    Last edited by G35Coupe; 2010-09-24 at 07:37 AM.

  2. #2
    My iPhone is a Part of Me Madman604x's Avatar
    Join Date
    Aug 2009
    Location
    Canada
    Posts
    655
    Thanks
    38
    Thanked 43 Times in 43 Posts

    is your computer 's host file edited to point to Cydia instead of Apple? that could be why it keeps failing.
    60% of the time, it works every time.

  3. #3
    Livin the iPhone Life
    Join Date
    Oct 2009
    Location
    Europe
    Posts
    2,830
    Thanks
    76
    Thanked 382 Times in 368 Posts

    The 'not eligible' error is because you're trying to restore to a version that is not the newest one. Apple has made it so it requires an Apple signature when restoring. Each time a new firmware is released, Apple stops signing requests for the earlier firmware. This means that you can only restore to the newest version which is 4.1

    That being said, try booting the phone using blackra1n. That way you'd also jailbreak it at the same time (I think). Another thing to try is simply getting out of DFU the normal way: press and hold both power and home button until the screen flashes (should take 7'ish seconds) and then let go of both buttons immediately. Wait a second or two and then boot up normally.

    Last thing, if you do restore to stock 4.1, you won't be able to jailbreak or unlock for use with another carrier. While the jailbreak for 4.1 is close, the unlock likely won't come until after 4.2 is released, or possibly even longer after that.
    We're all just toymakers in the game of life.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •