Results 1 to 8 of 8

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: iPhone 4 won't restore, device isn't eligible...!?

  1. #1
    Default iPhone 4 won't restore, device isn't eligible...!?
    hey guys,
    Very long story behind what I'm about to tell you, so I'll keep it short.

    I have a friend who gave me an iPhone 4 to unlock for him, as a reflex, immediately after getting it, I put the phone in DFU mode and hit the restore button. (4.0 restore)

    I got an error that looks like this: "The iPhone 'iPhone' could not be restored. This device isn't eligible for requested build."

    I don't want to restore it with 4.1 since I won't be able to unlock it. So question is, is there a way I could bypass the whole 'iTunes checking eligibility thing' or is there a way I can restore the iPhone without iTunes?

    All suggestions will be appreciated,
    Thanks,
    Alex

  2. #2
    Retired Moderator stlcaddie's Avatar
    Join Date
    Jul 2007
    Location
    Saint Louis, MO
    Posts
    1,088
    Thanks
    140
    Thanked 128 Times in 90 Posts

    What fw is it at right now?

  3. #3
    I don't know the current fw version, the phone was given to me locked and deactivated without a sim, so my only option was to restore it, i never found out the fw version.

    however between my last post and this one, i figured that apple won't allow me to restore to same fw if newer one is out, so, I'm guessing it's running anything under 4.1 I'm gonna try restoring with 4.0.1, maybe if I'm lucky it's been running 4.0 all this time

  4. #4
    Apple won't let you restore with anything less then the newest firmware. If you have the shsh blobs you can restore it. If not you might still get 4.0.2 but you will probably have to install 4.1

  5. #5
    Livin the iPhone Life screamforme02's Avatar
    Join Date
    Dec 2007
    Location
    In All of Your Hearts
    Posts
    1,635
    Thanks
    57
    Thanked 125 Times in 117 Posts

    use an older version of itunes and ctrl shift restore with a copy of 4.0.1 or 4.0.2. i stayed with 4.0.1 cause i like jailbreakme.com
    Hey! A Restore Never Hurts It's True!

  6. #6
    will using an older version of itunes really work? i guess it would be one that does not check shsh blobs?

  7. #7
    I'm trying that now, although I doubt anything under iTunes 9.0 will recognize the iPhone 4

  8. #8
    let me know, i have the same issue

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •