Results 1 to 7 of 7

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Cannot get Iphone4 to connect via WINSCP

  1. #1
    Default Cannot get Iphone4 to connect via WINSCP
    Hi all.

    I am looking for a bit of assistance with connecting to my Iphone4 via WINSCP. I have downloaded SBsettings and Openssh but it won't connect to WINSCP.

    I get the message "network error: Connection refused" and then keeps trying to reconnect.

    I'm using my IP address as the Host name, using "root" as the username and "alpine" as the password. Some places say to change the "File Protocol" to "SCP" but others don't. I've tried it in both. It worked fine on my 3G but now I can't get it to work on my iphone4.

    Can anyone offer any assistance please?

    It's on IOS4.0 and I don't want to upgrade.

    Thanks
    Mark

  2. #2
    I'm using my IP address as the Host name
    Are you using your phone's IP Address or your computer?

    Some places say to change the "File Protocol" to "SCP" but others don't.
    Keep it on SCP.

    Also, is your screen on or is the phone sitting the with the black screen saver?

  3. #3
    Hi and thanks for the reply.

    I'm using my phone's IP Address.

    Also the screen is on when I'm connecting. As soon as the screen goes off the wireless turns off so I make sure the screen stays on.

    Thanks
    Mark

  4. #4
    Make sure your QOS Engine is disabled in your router settings. I have a Dlink DIR-615 and it would take me forever to connect, then I loaded Cydia and scrolled down the home page and by chance saw the topic on SSH followed the steps, turne QOS off and it connects instantly now.

    EDIT: I only thought this fixed it...same problem is back now.
    Last edited by iJunkie68; 2010-08-19 at 05:07 AM.

  5. #5
    iPhoneaholic reddawg's Avatar
    Join Date
    Sep 2008
    Location
    Massachusetts, USA
    Posts
    430
    Thanks
    39
    Thanked 71 Times in 59 Posts

    Open a command prompt on your Windows Vista PC and try pinging the IP address of your iPhone 4. If ping fails, it's possible that your Vista firewall is blocking the connection. Try disabling the firewall and see if WinSCP is able to connect to your iPhone 4 using "SCP" protocol and port 22.

    One last thing, make sure the SBSetting toggle for SSH is not turned off on your iPhone 4.
    "When I die, I want to go peacefully in my sleep like my grandfather did...not kicking and screaming like the passengers in his car." -- Unknown

  6. #6
    iPhone? More like MyPhone skater38053's Avatar
    Join Date
    Jul 2010
    Location
    In your mom
    Posts
    131
    Thanks
    18
    Thanked 15 Times in 13 Posts

    I've noticed on my i4 that I ether need to load a page on my phone or refresh my email. That way my phone is sending out a signal. Or simpley unplug your wireless router for a few mins(I couldn't connect for hours. And kept getting the same message as you) plugged it back in and connected in seconds

  7. #7
    I had the exact same issue as you the day jailbreakme came out. What I ha to do is reinstall sbsettings/openssh/ssh toggle and it worked like a charm. I'm guessing something went wrong during the install. Hope it helps, just throwing my 2 cents out there

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •