Results 1 to 12 of 12

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Is iTunes 9.2.1 Safe for Unlocked & J/B iPhones?

  1. #1
    Default Is iTunes 9.2.1 Safe for Unlocked & J/B iPhones?
    Is itunes 9.2.1 safe for jailbreakers? i got an unlocked and j/b iphone. I need to upgrade my itunes 9.0.2.25 to the latest version, which is 9.2.1, to get it to detect my ipad. Is this version of itunes safe for unlocked and j/b iphones?

    .

  2. #2
    9.2.1 works good for me, i already jb and unlocked 2 iphone 4's and my ipad also, make sure you sync 'em before jb and unlock.. gl

  3. #3
    Quote Originally Posted by llj143 View Post
    9.2.1 works good for me, i already jb and unlocked 2 iphone 4's and my ipad also, make sure you sync 'em before jb and unlock.. gl
    i dont understand what you said. what do you mean by "make sure you sync 'em before jb and unlock"? you mean, sync the idevices AFTER you j/b and unlock them. Why do I have to sync them before j/b and unlocking? This doesnt make sense.

    Just to let you know, my ipad isnt j/b yet, but my iphone is. And i cant get my itunes to detect the ipad, which is why i need to upgrade my itunes to version 9.2.1. is this what you mean? i really dont understand.

    .
    Last edited by koolx; 2010-08-17 at 04:48 AM.

  4. #4
    Retired Moderator
    Join Date
    Jun 2009
    Location
    Alhambra, CA
    Posts
    16,904
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    If jailbroken via Spirit, it would provide a problem. If not by Spirit, it should be ok.

  5. #5
    im not sure what it means, but thats what the instruction says just like in spiritjb site, as for my iphone 4, i followed a guide for 4.0.1 in other site, which the instructions says that i have to sync with itunes first before j/b and unlock..

  6. #6
    Retired Moderator
    Join Date
    Jun 2009
    Location
    Alhambra, CA
    Posts
    16,904
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    I meant youre not suppose to use Spirit with iTunes 9.2

    If you were jailbroken with Spirit before it could cause problems with iTunes 9.2
    Last edited by i.Annie; 2010-08-17 at 10:14 AM. Reason: Automerged Doublepost

  7. #7
    Sorry to hijack, but I have a related question. I have a jb 16g 3gs 3.1.2 broken with spirit.*

    Bought a new computer and installed iTunes. 9.2.1.4

    my old computer only has dialup so I could never upgrade it to 9.*

    Well, we bought our daughter an iPhone a couple weeks ago. (It's not JB) and in order to get her phone set up, I had to hook it up to the old computer (for the music files) and I downloaded the newest version 9.2.1.5 using the new computer to memory stick and installed it on the old one.

    I haven't synced my phone with the new iTunes yet... On either computer.*

    What sort of "problems" will I encounter? And what do I need to do to avoid them? **

    Thanks so much!
    Last edited by iSoConfused; 2010-08-17 at 06:55 PM.

  8. #8
    Retired Moderator
    Join Date
    Jun 2009
    Location
    Alhambra, CA
    Posts
    16,904
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    Possibility of phone crashing, bricking...anything along the lines of your phone failing.

  9. The Following User Says Thank You to i.Annie For This Useful Post:

    iSoConfused (2010-08-17)

  10. #9
    Quote Originally Posted by Anniex423 View Post
    I meant youre not suppose to use Spirit with iTunes 9.2

    If you were jailbroken with Spirit before it could cause problems with iTunes 9.2
    Ok, i'm a bit lost here. please clarify things for me:

    1) I got an iphone 2G running 3.1.2 thats unlocked and j/b. I used a custom FW to unlock and j/b my phone. Can I upgrade to itunes 9.2.1 without risking my phone being locked out and un-jailbroken?

    2) Since I got an ipad thats not j/b yet, and the fact that I cant use an ipad thats j/b with spirit on the newest version of itunes, with what FW can i still j/b my ipad?

    3) Is spirit made for ipad or the iphone?

    .

  11. #10
    Retired Moderator
    Join Date
    Jun 2009
    Location
    Alhambra, CA
    Posts
    16,904
    Thanks
    137
    Thanked 2,202 Times in 1,924 Posts

    1) its a 2G, no further update from Apple or the dev team on this device. So no, iTunes wont affect a 2G phone, especially if it isnt jailbroken with Spirit. Like I said, you jailbreak a phone with Spirit before, iTunes 9.2 gives problems.

    2) Since jailbreakme is out, Spirit really isnt necessary. Jailbreakme will JB 3.1x and up.

    3) You may use Spirit on the iPad. Jailbreakme would probably be a better option.

  12. #11
    So to sync, I need to get an earlier version of iTunes?

  13. #12
    Quote Originally Posted by Anniex423 View Post
    1) its a 2G, no further update from Apple or the dev team on this device. So no, iTunes wont affect a 2G phone, especially if it isnt jailbroken with Spirit. Like I said, you jailbreak a phone with Spirit before, iTunes 9.2 gives problems.

    2) Since jailbreakme is out, Spirit really isnt necessary. Jailbreakme will JB 3.1x and up.

    3) You may use Spirit on the iPad. Jailbreakme would probably be a better option.
    Anniex423, thanks for clarifying everything for me. i greatly appreciate all ur help.

    .

    Quote Originally Posted by Anniex423 View Post
    1) its a 2G, no further update from Apple or the dev team on this device. So no, iTunes wont affect a 2G phone, especially if it isnt jailbroken with Spirit. Like I said, you jailbreak a phone with Spirit before, iTunes 9.2 gives problems.

    2) Since jailbreakme is out, Spirit really isnt necessary. Jailbreakme will JB 3.1x and up.

    3) You may use Spirit on the iPad. Jailbreakme would probably be a better option.
    Anniex423, i forgot to ask you something... is it possible to install itunes 9.2.1 WITHOUT quicktime, like, quicktime lite? I got quicktime lite but for version 9.0.2.25.. Is there a lite version for 9.2.1?

    Also, will installing 9.2.1 present me problems since i got a lite version itunes 9.0.2.25 without quicktime?

    .
    Last edited by koolx; 2010-08-18 at 02:44 AM. Reason: Automerged Doublepost

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •