Results 1 to 14 of 14

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: Ultrasn0w possibly still causing battery drain....

  1. #1
    Default Ultrasn0w possibly still causing battery drain....
    I was talking to BigBoss last night about the infamous battery issues that many of us are having. After several tests, we finally agreed upon removing Ultrasn0w (1.1-1) and running it again. Posted below are my results with various settings enabled and disabled. You will notice that 1 hour standby WITH ultrasn0w yielded a 3% drop vs. a 0% drop withOUT ultrasn0w.

    I realize that 1 hour tests are perhaps not the most accurate, so I will be continuing this with an overnight test withOUT ultrasn0w. I will then re-install ultrasn0w and test against another overnight run.

    In the mean time, here are the results I have logged over the last few days:


    All tests started with 100% charge.

    #1
    88%
    Usage - 18mins
    Standby - 4 hours, 10 mins
    Wifi Off
    3g on
    Nimbuzz running
    WITH ultrasn0w

    #2
    97%
    Usage - 1min
    Standby - 1 hour, 10 mins

    Wifi Off
    3g Off
    Location services - off
    Push off
    Pretty much any battery draining service is turned off
    No apps running
    This is WITH ultrasn0w

    #3
    73%
    Usage - 10 mins
    Standby - 12 hours, 15 mins
    Wifi on
    3G on
    Push On
    No programs running
    WITH ultrasn0w

    #4 - ultrasn0w removed
    100%
    Usage - 1 min
    Standby - 1 hour, 2 mins.

    3g ON
    Wifi ON
    Location ON
    Push ON
    No Programs running
    ultrasn0w removed


    All tests are done with JB and SBSettings with current mobile substrate.

    If you have any suggestions or requests, feel free to respond.

    Here is a screen shot of the last test (plus 24mins):

    Last edited by BaileyMoto; 2010-08-16 at 04:49 PM. Reason: Automerged Doublepost

  2. #2
    Thanks for doing this.

    Has anyone from the Dev Community seen this info or something similar?

    Have you compared running processes between running the unlock and not?

    From what I can tell, the last update fixed wifi-to-cellular handoffs relating to standby, but I do not think they adjusted a stop/start for the process.

  3. #3
    As promised, here i an over night run w/o ultrasn0w installed. This test is done with everything on, including push notifications that kept updating overnight, such as Facebook. Looks like 3% for 8 hours of standby, 7 mins of use (I assume this was due to the push updates, which also turned on the backlight). Compare that with 3% over 1 hour above when ultrasn0w was installed and all services were turned off.

    I am going to run this again, but with services turned off. Then I'll follow it with ultrasn0w installed.

    97%
    Usage - 7mins
    Standby - 8 hours, 21 mins
    3G on
    Wifi on
    Push on
    Location on
    No apps running
    ultrasn0w removed

    Last edited by BaileyMoto; 2010-08-17 at 05:25 PM.

  4. #4
    But the above still had a jailbreak, right?

    This looks good. Totally reasonable - What does "no apps running" mean?

  5. #5
    Quote Originally Posted by kidblue View Post
    But the above still had a jailbreak, right?

    This looks good. Totally reasonable - What does "no apps running" mean?
    Correct, it is still JB and there are no apps opened or running. For example, you'll see that in the first test, I had numbuzz running under multitasking during the test.

  6. #6
    So you just opened the multitasking menu and removed anything from that list?

  7. #7
    Quote Originally Posted by kidblue View Post
    So you just opened the multitasking menu and removed anything from that list?
    I started from a fresh restart and also verified by checking processes within SBSettings.

  8. #8
    And now you're testing "all-in" with ultrasn0w?

  9. #9
    Quote Originally Posted by kidblue View Post
    And now you're testing "all-in" with ultrasn0w?

    I'm going to do an 'all services off' without ultransn0w, meaning I will be turning off 3, wifi, push, etc. Looks like it doesn't make any difference to turn off wifi or any of the other services. The next one after that will be with ultrasn0w, which will include both tests: with and without services running.

    Here is the test with ultrasn0w installed and NO services (3g, wifi, location, push, etc) or apps running in the background:
    Next test will be with ultrasn0w installed.

    Last edited by BaileyMoto; 2010-08-18 at 09:44 PM. Reason: Automerged Doublepost

  10. #10
    So the above is ultrasn0w with everything "off", just in standby?

  11. #11
    Quote Originally Posted by kidblue View Post
    So the above is ultrasn0w with everything "off", just in standby?
    Correct, I did, however, take 2 short phone calls during this test.

  12. #12
    And next you're planning on doing a test with ultrasn0w and actual usage?

  13. #13
    Well, I re-installed ultrasn0w and the standby didn't degrade. So, I'm at a loss. I guess I will start comparing usage times.


  14. #14
    Is ultrasnow a one use thing and is it possible for it to be removed without losing the unlock?

    I sure hope the devs and you guys can pinpoint this issue down.

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •