Results 1 to 6 of 6

Your favorite Apple, iPhone, iPad, iOS, Jailbreak, and Cydia site.


Thread: iPhone 4 App/iTunes crash on purchase

  1. #1
    Default iPhone 4 App/iTunes crash on purchase
    Basically just like the title. I have an iPhone 4 that is jailbroken and whenever I try to purchase something in the iTunes or App store it just closes. It should ask for my password to verify the purchase and then close and start downloading but it doesn't. So effectively, I can't buy anything on my phone. Only though iTunes on my computer.

    Anyone ever hear of this and know how to fix?

  2. #2
    same prob here but I have an iPhone 3GS

  3. #3
    Same here too. 3GS, 4.0.1 jb.

    Not sure if it happens in the app store .... But it def happens when i try to buy from iTunes.

    I don't try to buy off iTunes enough to know when it started either (ie, after installing a particular extension or app or something).
    Last edited by novadam; 2010-08-29 at 09:47 PM. Reason: ...

  4. #4
    Ok, I fixed it but not sure how. Wish I knew how to read a crash log. Anyway, I did three things:

    (1) uninstalled ReadMore jb app and rebooted;

    (2) then I took iTunes out of it's categories folder and put it on the springboard:

    (3) opened iTunes, logged out of my itunes account and logged back in.

    I was then able to buy songs again. I then reinstalled ReadMore and rebooted and tried to buy -- everything was fine. Then I moved iTunes back into it's categories folder and tried to buy -- everything was fine.

    So I don't know whether it was bad initial install of ReadMore, whether it was just logging out of iTunes and back in, or what. But it works now.

    Like I said, I didn't have this problem in the app store -- I tried buying an app this morning before I did any of the above, and it worked fine.

    If I were you, I'd first try opening the iTunes app and logging out / logging back in. It's the simplest.

    Hope some or all of this helps.

  5. #5
    Default Apps not in Categories but in the Sprinboard!
    So, I found the solution! I had the AppStore icon in one of the folder I created with Categories. I just took it out, put it back to the Springboard, and I can install apps now as usual.

  6. #6
    If the App Store is hidden with SBSettings, or inside a Category, it cannot authenticate. Just leave it on the regular dashboard, respring and you will be fine !

Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •